MyCloud now seeing all Ext. USB 3.0 drives as 0 kb

DEVICE: MyCloud 2nd Generation.

At one time this device worked flawlessly. Now when I connect an external drive to it, it sees the drive as 0 bytes. This occurs even with USB thumb drives. I’m hoping there is a simple fix for this. I’m on the most recent firmware. Any help will be appreciated.

I have stayed away from the latest firmware, because it seems to have a long list of issues associated with it. This sounds like an issue with the automounter.

I would need to see dmesg output to know more.

dmesg_output.txt (79.0 KB)

Here is the output. I hope you can resolve this for me. Thanks for investigating.

Sorry for late reply;

Looking at this dmesg, it looks like the USB driver stack is having problems interrogating USB devices, and timing out when enumerating them, and communicating with them.

It gets to the USB disk device, has issues when communicating, and then sets the device’s capacity to zero.

I would advise reverting the upgrade you recently performed, and see if that fixed the issue.