MyCloud not in NETWORK list but available as storage

#1

I have installed and configured OK MyCloud. I can access it via the Dashboard. But instead of showing up in the NETWORK tab in Windows Explorer it is listed as Storage. So I cannot map a drive on the shared folders (that I can access ok). WDSmartWare has successfully made a backup of my files and I can copy files from there to the share folders when logged via MyCloud.
I am using Windows 10 with (normally !) all updates installed.
Any idea ?

Thanks.

#2

Because your using Windows 10 you may want to review the following discussion that has a variety of things to check on Windows 10. In particular ensuring both the Windows 10 PC and the My Cloud are using the same workgroup name. That Windows 10 has NetBIOS over TCP/IP enabled. That the Windows 10 network setting is configured for Private and not Public. And above all, ensure Windows 10 has all the latest updates applied.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576/

From that discussion, try General Method 1 OR General Method 2, then move on to trying Windows 10 Specific Method 1 through Windows 10 Specific Method 5.

#3

When you open up Windows Explorer and under Network>Storage are your able to see your shares? If so select one and do a right click on it. You should be able to Map it. See example image below.

#4

I cannot map,a network drive as it does not show in the network list . Screen copy in attached document.
And now after reboot of my PC and of the MyCloud it does not show anymore, but c
I can still log-on and connect with admin. SmartWare sees it OK.
I checked NetBIOS over TCPIP and it is set as ‘default of the router’, which I did not found but guess it is enabled.
I have reserved th IP address of MyCloud in the router (acting as DHCP server).
The network is PRIVATE.
Network discovery and file sharing is ON.
I put the same name for the workgroup, but it does not appear either in this (but I do not know ho to specify the workgoup password).

#5

Sorry, I did sometinh wrong and sent the text too early.
Here is what I got after the reboot of my PC and of MyCloud :

After some time it came back in Windows Explorer, but always at the wrong place.

I will try with NetBIOS over TCPIP ON, but as I can see my wife’s PC I guess it is turned on.

Now what ?

#6

I checked the network card properties and NetBIOS over TCPIP is enabled. so …
Thanks.

#7

Eric,

I can see from your screen shots that you are looking in the wrong place in File Explorer. You are looking in the left menu tab “This PC” but you need to go down to the next main tab called “Network”. So, close This PC tab and open Network tab below.

Do you now see your My Cloud?If you do, open it, but if you don’t Refresh the Network tab by placing cursor back in Network and look at the display for a circular arrow near top right of screen. When the cursor is over that arrow it says Refresh Network, so click on it.

Do you now see your My Cloud 9and the Public folder)? You should , so let me know if you do or don’t see it. The Network tab is where you find your My Cloud as a shared device; the This PC is displaying data as DLNA/UPnP format and NOT what you need. You need to always look in Network for it.

#8

I fopund a (stupid) solution : just add a network location giving the Myxloud name,and now it is in the network tab !