MyCloud not connecting to new Asus Router or found by laptop

I recently changed my old internet provider TalkTalk router at quite an expense with an Asus DSL AC68U and attached to that an Asus RT AC88U for security, amount of usable ports and extended Wi-Fi coverage.

However, now the 4TB MyCloud (which worked perfectly well on the old cheap router) will not connect showing only a solid white light. I have tried re-booting it, starting from scratch following the guides provided but it just stays offline.

My laptop doesn’t even connect to the ip address of the MyCloud and can’t even find it when I ask it to search for my component.

Pleas can anyone help as I have all my photos and TV programmes and Movies I have saved on it, but also my i-Tunes music library on which I have burned over 1500 CD’s and from which my Sonos music system accesses my music.

I haven’t got a clue where to start and being of the older generation, computers are mostly an enigma to me, which is why when I buy anything I tend to go for easy set-up, step by step instructions or plug and play. Which is great when they work but if they go wrong…I haven’t a clue. So, if you could bare that in mind if replying I would be very grateful.

My laptop is an HP Pavilion g6 CORE i5 running Windows 10 64bit.

Many thanks

Paul.

@Pompeyexile Did you give your new router the same User Name and Password as your old one? How is the Asus RT AC88U connected, by cable or WiFi?

Here is an example image of what I did with my Linksys Wireless Range Extender.
image

I did the same for my 5 GHz settings.

Hi Cat0w

My Asus 88U which does not have a modem is connected to the Asus 68U which does have a modem via a cable. Both are picked up by my i-phone and i-pad but only the 68U is picked up by my laptop.

My new Asus routers have different passwords than my original TalkTalk one but when they were set up originally both were picked up by my laptop but the MyCloud has never shown up since connecting them.

Looking at the Asus 88U GUI page on my i-phone it shows all the different accessories I have attached (Hive home heating and lighting, WD live TV, Amazon TV, laptop, i-phone, i-pad) which work no problems but not the WD MyCloud.

In devices on my laptop the MyCloud device is showing and when clicking on properties in the UPnP it shows the ip address for my WD MyCloud is 192.168.1.37 but my laptop simply says timed out.

Oh and I did connect the MyCloud directly to the 68U but again nothing.

Thanks

Paul.

If you have put a second router behind the first you may run into problems unless you put the second router into Access Point (AP) mode or disable the DHCP server and Firewall on the second router.

What may happen if you don’t reconfigure the second router is devices may end up with different IP address subnets which may prevent devices connected to the first router from seeing devices connected on the second router.

If using an Asus router they may have the AP setting under Administration > Operation Mode.

The screen capture above is taken from a second Asus router connected via ethernet wire to my main Asus router to extend the number of ports. As the screen capture indicates the second router is in Access Point mode. All devices on the second router can access the My Cloud attached to the main first router.

Also if one previously set a static IP address within the My Cloud Dashboard > Settings section they may need to either perform a 40 second reset or reaccess the My Cloud Dashboard > Settings page to ensure the static IP address is in the same subnet range as the reset of the local network. It is often better to reserve a static IP address for the My Cloud within the router’s administration page settings to avoid this particular issue of a static IP address being outside the local network range.

https://support.wdc.com/knowledgebase/answer.aspx?ID=13986

Hi Bennor,

Thanks for such a quick response, your help is very much appreciated. As I said, I am really not too good with computers so can I ask a couple of daft questions.

I managed to access the 88U router section as described by connecting it directly into my laptop and did exactly as you said. However, upon choosing the option a new screen pops up saying ‘Internet LAN IP setting’ with a choice of Automatic or Manual. If I choose Automatic it asks me to assign a unique name or SSID to help identify the network but the network name and wireless security password are already filled in. It also asks if I want to separate the 2.4GHz and 5GHz and if I say yes, the network name and security for the 2.4GHz are already populated but the 5GHz is not and it then asks me if I want to copy the 2.4GHz details into the 5GHz network and security.

Should I say yes to all?

You also mentioned 'All devices on the second router can access the My Cloud attached to the main first router '. So, should I connect the WD MyCloud to the first router (68U) rather than the 88U where all my other devices are connected?

Sorry for being so dumb but I just don’t want to do something that may exacerbate the problem.

Thanks

Paul

At that point in the quick setup the Asus interface is asking you to setup the WiFi SSID names (and password) for the 2.4 and 5 GHz bands on the second router. You can fill in that information manually to have different SSID names and passwords for each of the two bands. Or copy the information from the 2.4 Ghz fields to the 5 GHz fields. It is typically suggested to use different SSID names for the second router so as to not conflict with the first router if one keeps the WiFi enabled on the second router.

When the second router, that is attached to the first router, is properly configured you can attach the My Cloud to a networking port on either router and all devices, connected to both routers, should be able to access the My Cloud.

Basically what you are doing by changing the settings on the second router is ensuring all devices on the local network use the same IP address and making sure network traffic that flows from the first router to the second router is not blocked by the second router’s firewall.

Hi Bennor,

I have done as you suggested but my WD MyCloud is still not visible and doesn’t connect and has just sat there with a solid white light for over six weeks. I have unplugged it powered it down and pressed the reset button as per the WD instructions but nothing seems to work.

I have all my i-tunes (over 1500 burned CD’s), photos, downloaded TV programmes and films which I can no longer access. Having looked through the forums it appears that this is an issue with the MyCloud and there is nothing I can do (not being an expert) and therefore it seems have lost all my data.

All of this occurred because I swapped it from an old ISP provider router to a new supposedly more powerful and robust router. Looks like I should have left well alone.

To say I am disappointed (not with you, you have done all you can to try and help) is an understatement and I don’t think I will be purchasing any other WD external hard drives.

Thanks again for your help

Paul

Try taking the second router out of the mix and have the My Cloud attached to the first router. A white front LED indicates a possible issue other than router related. See the User Manual for your My Cloud to see what the front/back LED colors indicate.

One other suggestion as a troubleshooting step. If you have a cheap network switch, connect that switch to the first working router, then connect the My Cloud to that switch and see if the My Cloud boots correctly and is accessible.

Hi Bennor,

This is what the manual says regarding the solid white light.

Initializing

White

Solid

  • Device has begun loading the Operating System (OS).
  • Firmware update in progress.

It also happens when the MyCloud is unable to negotiate a link speed on its interface. This can happen with some networking equipment, most notoriously being the ATT Uverse routers, but your ASUS equipment might also be impacted.

As Bennor points out, the easiest solution to this issue is to place a gigabit switch between the router and the MyCloud.

We can possiby rule this out and or, confirm it as the source of the problem, by performing the diagnostic step he suggests-- Putting the Mycloud on a switch, and seeing if it boots properly.

Hi Wierd w,

I will purchase a gigabit switch, try it and report back.

Many thank

Paul