MyCloud networked drive not waking up/showing up

I have a desktop PC running Windows 7 Professional, and MyCloud 3TB hooked up via Cat-5E to a switch. Both are talking on a gigabit lan connection.

I have a portable 2TB external hdd hooked up via the USB interface on MyCloud, and these are the only files I acess. I have it mapped as a network drive in Win 7 using the shortcut \Wdmycloud\my_passport since that is the root of the external hard drive. I do not have any files saved on MyCloud’s hard drive, and all I want to access is the USB drive.

I used to log into Windows, and everything would be great… the drive would show up right away. Lately (within the last month), the shortcut will not work, and the map to H: does not show up. It will only show up if I go to (the ip address for MyCloud) and it loads the http screen. 

It seems to me that this is some glitch brought on by a new firmware? Seems like MyCloud is asleep and not waking up? I tried looking at some of the options and couldn’t find anything useful, from the http screen. 

Don’t know if it matters, but I also use Twonky to share only 1 folder with mp3s, and I have turned off all the other shares in Twonky. I haven’t tried streaming media while MyCloud is asleep, but I’m sure it would fail as well. Basically, I want this drive always accessable and I don’t care how much power it is using. I never want it to sleep and I always want it to be accessable to Windows. (Drive Sleep is currently off).

Any help is appreciated. Thanks. 

You can try mapping the drive again.

Also, try resetting the drive to clear out any settings that might be causing the issues.

1 Like

Re-mapped and this actually solved the issue. Thanks.