Mycloud network disappeared in windows file explorer

I have had mycloud home connected as a network for about 18 months without any issues (as a User Private Space). I took my laptop on holiday last week and the first time I tried to save a file from my computer to the mycloud home through the network, it had disappeared. I can’t remember for sure but I believe I received a notification saying my “mycloud” had just been updated. I received an update notification while I was on holiday but I can’t remember if it was before or after I tried to save a file. I have tried a few things to get it back, restart the device, turn on SMB 1.0/CIFS File Sharing Support, search for my device plus the last 6 digits of the user name. After doing this, a new network appeared as a LAN but I can’t do anything with it. the folders inside are only “public” and “Timemachinebackup”. Both are empty. According to a page i found I’m not supposed to use it as a LAN. How do I create it as a User private Space like a Z: drive?
Any help would be amazing.

Hi @andlew,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

thanks. i didn’t realise this was an option. I have submitted a troubleshoot request, so let’s see what happens