MyCloud Missing From Finder After WD Update

Mac Book Pro - mid '12 - OS X El Capitan - 10.11.4

Have been using MyCloud fine the last couple of weeks.

The cloud itself - which I had renamed - was always in my finder side bar. Plus a separate “MyCloud” icon under the Shared tab.

I updated the firmware via WD app after several prompts and now, cannot find my renamed cloud folder in finder.

The “Shared” tab still shows - although I never used this. And can’t log in to anything there anyway.

When I click WD in the top bar - my device still comes up - but when I click on it, it doesn’t take me to the folder as it usually would.

It is all still there when I log in via the web browser.

Please help!

1 Like

Have the exactly same problem with my Macbook Pro 13’ - Mid 2012 - High Sierra 10.13.6

Looking forward to your help!

Were you able to connect fine before?

Yes, without any problem. Yesterday I updated to the new wd discovery version 4.3.327
Since then the double klick on the device is not working anymore. Access via Webbrowser works without any problem.

Ah yeah! Exactly that! I hope someone has answers!

I’m having the same issue!!! I can view my files online but I have all my files that I need for designing in there and cannot work on them easily and conveniently without them being available on the side bar!!! Please help!!!

Same issue here since I last updated the app! This was my primary means of accessing it, so this is very annoying. Any news on a fix??

Found this on another thread -

Uninstall the previous version - reboot - reinstall the version above - do not update!

I can now click on the cloud storage via the WD app up top and it takes me to my folder in the finder :slightly_smiling_face:

I was experiencing the same issue. VeeBrown’s solution worked for me to start off, but then it automatically updated the version and I was back at the same place. How can I stop this from happening? is it because I have it installed in different computers and wants to keep the same version throughout? Please let me know?

Also, if anyone from WD is reading this, can you let us know when this issue gets sorted in the update?



Turn off your “silent updates”

It’s in the settings tab.

You’ll have to uninstall then reinstall again. But before you sync your cloud, turn off silent updates and do not update when prompted.

Hope that helps!

1 Like

I can confirm the latest release has broken this, have two MacBook Pro’s on High Sierra, both working with WD Discovery just fine, then the latest release broke it. They applied a patch to fix access for M1 chips, and in so doing seem to have rendered the product non-functional for 99% of Mac users. They’re also being very quiet on the topic. It would be much more helpful if they acknowledged the problem and let us know they are on it.

1 Like

Just saw this on another thread

Thanks VeeBrown, this solved it for me!

This solution doesn’t work for me - 2015 MBP and Big Sur. The fix back in December worked and I wasn’t thinking when I clicked on ‘update’ earlier. I have tried repeatedly uninstalling and installing various versions, none work, including the link ot the one that did work for me in December. It also seems to be nearly impossible to stop ‘silent updates’ from running as when it reloads it seems to default to it.

I have the same problem, I uninstalled and installed and now I can’t log in to MyCloud

Same problem for me - have only recently purchased My Cloud Home. Worked fine for a week now the desktop icon has gone and can’t connect via Finder. All okay via browser. V annoying!