MyCloud Mirror wil not upload files. Please read symptoms before drawing conclusions

Uploading from iOS devices continues to fail.

  • app accesses drive fine.
  • permissions are correct (directories, shares etc).
  • firmware and iOS software up to date.

What happens?

If in photos app, select a photo…use share tab … select WD and the directory (tried many.) status bar indicates movement, sometime stops 87% through. Sometime shows 100% uploaded (but nothing uploaded.) No errors.

If in the IOS app…select upload a photo…select location (tried many) and hit upload - nothing happens. No errors, no indications, no change.

Rebooted. No change. What us the point to the hardware if can’t upload a simple photo?

Also deleted app from phone, readded. Deleted user, readded.

Is this happening on local connections or in remote connections? You mention iOS devices in your post, does this mean you have already tried other devices?

Called support. They tried from their own devices including Android and were unable to get files to actually upload. They requested a report and stll waiting for an update.

Have tried everything I can think of… including deleting and rebuilding port-mappings, factory restores, removing.readding users and devices, most current software and firmware versions.  Everything worked … then didn’t … without any changes to configurations that I’m aware. 

• Files upload fine from the desktop. Not a single file will upload from any WD iOS app (including WD Photos).

• Can access the drive remotely just fine, and even create new directories/folders.

• Can download just fine.


Surprised by a support call from WD today. Happy, just wasn’t expecting it…been many days. The rep, however, did not research all the other steps or any of the history. After a full hour, the rep was unable to upload from his own device and said he would need to further research —> the same exact stopping point as the last rep several days ago.

So I am able to upload using the WD app when the iOS device is on the same network, but not when switching to other networks (same as the tech support). Thinking there might corrupt permissions however not seeing a means to repair in the utility. Unable to change permissions for any existing shares or users… just new ones.

btw - why will these fields not respond to spelll checkkkk?

OK! So, finally I have fixed this problem: I could upload files from my network, but was unable to do this from outside networks. It took me about a week for reading forums and boiling brains.
Below are steps leading to the victory:

  1. I have downgraded Firmware of my WD MyCloudMirror from 2.11.133 to 1.05.26.
  2. Then I have upgraded it back to 2.11.133.
  3. Pushed reset button on the back of the unit for 5 seconds.
  4. Reinstalled the device.
  5. INPORTANT!!! Reinstalled all WD software on both Mac and Win machines.
  6. All worked! I deserve a beer!

PS. By the way, initially IP was set to a fixed. Now it is DHCP assigned.

I hope this helps.
(Now it works well and uploads any size files from MacBook, Sony Vaio, iPhone when all these devices are located far away from “Mothernet”. :slightly_smiling:)
I have not tried uploads from Android - I am not that smart to operate this sophisticated OS.

Here is an update. Sadly uploading files broke again in 2 weeks.
This time I found the other way to fix it:
I have deleted all registered devices and registered them again with new authorization codes.
The trick is that the new device when registering should be in the outer network (not in the same where WD is).
This worked for me and now all goes fine: Any size files are uploading to WD from any place in the world.

Gave up - great potential but required too much hand holding, tweaks and not available when needed