MyCloud Mirror stuck in amber and blue power cycle and not showing on network


I have a 8TB mycloudmirror (2*2TB) which has been running away for a number of years quite happily

Recently I did notice a red light for a few second on disk 1 - so I restarted it but now the power light flashes orange then back to blue, lots of disk whirring sounds but then it stops and start the cycle again - ie power light flashes orange, disk whirring sound the power light flashes blue then back to the orange – it also does not show up on the network – no ip address

The disk 1 and 2 lights are blue

I have read the orange flashing can be network and indeed the Mycloudmirror does not show up on the net work

As there had been a red light on disk1 – I pulled disk1 and tried a reboot without it in and it works fine on just disk2 in slot2– starts up , shows up on the network and no issues

Figured it was the disk and bought a replacement – powered the unit down, put the new disk in slot 1 - and no luck - ended up back in the powerlight flashing orange and blue cycle with lots of disk whirring sounds and not showing up on the network - disk1 and 2 lights are blue – pulled the new disk1 back out of slot1 and it boots up fine again on just disk 2 in slot2

I looked at the storage utilities and it shows the disk2 profile as good

Then pulled the working disk2 and put just the original disk1 back in slot1 - (should have tried this before I purchased a new disk) and with the original disk1 in slot1 and no disk in slot2 – it booted up but had a blue flashing powerlight and a red disk light

And when I looked at the storage utilities, it showed the disk1 profile as bad – so I guess it does need replacing so not feeling so bad about buying the new one

I then pulled the disk1 and just tried it in slot 2 to see what would happen – and again it booted up

Then put the original disk2 in slot1 to see what would happen, boots up and still shows disk2 as good

Then lastly just put the original disk1 in slot1 and disk2 in slot2 - so back to where we started and it just booted up – what a surprise - utilities show disk1 as bad and disk2 as good and Raid shows Volume_1 as degraded - and there is a red light on disk1 on the front of the unit – so assuming disk1 is bad

So replaced the bad disk1 in slot 1 with a new disk and it went straight back into the power light flashing amber and blue and disk whirring cycle - and the device does not show up on the net work and wont boot up

Just to complete the test - I put the original disk2 in slot1 and the new Disk1 in slot2 – and again it just goes to the power light cycle of amber and blue and disk whirring – does not show up on network, no ip address

Then took out disk2 and just put the new Disk1 in Slot1 and it started up - showed disk as good but no configured volumes etc which is the case as it’s the first time this disk has booted up or been used

The left the new disk1 in slot1 and added Disk2 back into slot2 and– again back in to the power light cycle of amber and blue and disk whirring and not showing up on network

Now given up for the day and just removed the new disk1 from slot1 and left disk2 in slot2 - booted up fine so I least I know I have my data

Have been using my broadband router “currently connected devices” page so I know when its there or not and has and ip address and the standard mycloud mirror page for information – which is only available when the device has an ip address and on the network

So question is – how do I get this to boot up with a new drive as when it has 2 disks in it gets stuck in a loop

Any advice appreciated

Hello MarkT,

I would suggest you to contact WD support for assistance as it seems that there is some issue with the hardware of the device.

Apologies for resurrecting an old thread, but wondered if you had ever resolved this issue? I’m having an identical problem but can find very little info on it. The only difference between your post and my problem is that I have bought 4TB drives to upgrade/replace, as one of my 2TB has apparently failed. But like you, with a new drive installed the unit merely power cycles with orange / blue lights.

Richard hi

yes i did fix it in the end with the most unlikely of solution - it was the power block - ie these things are power heavy and need the correct output from the power block - i tried a new power block and it worked fine, re tried the old one and no go - retried the new one and worked fine

then a friend of mine also had one of these so for an experiment we tried my old power block on his - and his then showed the same issues as mine did - switched back to his own power block and fine again.

we think the power block we putting out a reduced power output and it just didnt have the juice to power it with 2 disks - still working fine to this day and i chucked the old power block away!


Astonishing! Can’t thank you enough.
I just went exploring in the attic and found a suitable ac adapter - low and behold it’s all now working as it should.