MyCloud Mirror slow and CPU high after corrupt/canceled file transfer

Heya there guys!

So, really odd thing happened a few weeks ago…
I tried copying over a file with ES File Manager from my phone to my NAS, it was a ~2GB big ISO file. However, the file transfer never really started for some reason, not sure if this is a fault of the app or from the NAS but anyways…
After that I tried to click cancel so the file transfer would stop but… nothing happened. It didn’t cancel, however it seemed to try at least. After that tho my MyCloudMirror (EX2) started to act really weird.

Connecting any computer to it takes ages now, around a minute or 2 for the shared folders like Public, my own User folder or others to show up in the Windows Explorer. Before that accident happened they were like 1-3 seconds maximum! Of course, not counting in the disks spinning up, that’s a different story, they do their job fine once I click on a folder.
However, as said once I click a folder when I go to \wdmycloudmirror I have to wait another few seconds or even up to a minute for it to respond. The disks are spinning up and seem to access already (you can hear the drive heads moving around already), so everything’s fine.
But, the explorer is stuck for this time, not responding, Windows 10 even tries to restart the explorer then…

This also happens when accessing it with my phone again so no, it’s not a Windows failure. Even other computers, laptops etc. need this time.

So, does anyone else have a suggestion besides resetting the MyCloud device?

Thanks already!


What comes to my mind first is to reset the unit but since you are trying to avoid that, try reaching out to WD Support to see if there’s anything else that you can try.