MyCloud Mirror Mapped Drives Don't Connect Immediately on Win10 Startup - Manual Intervention Req'd


#1

Greetings:

Dell Inspiron 7000 Laptop
MyCloud Mirror Gen 2.o
Windows 10

When I startup my laptop and open Windows Explorer, my mapped drives are shown with a red slash through them indicating they are not connected. They will remain that way until I use the mouse and click on the drives at which point they connect.

This is causing an issue with iTunes on my computer as I run iTunes library on MyCloud. So, when I startup the laptop and open iTunes, it can’t find the library until I manually open Windows explorer and click on the mapped drive where my library is located. I believe this is also affecting using iCloud on my computer for integrating with Outlook. I’m always having to sign out and back into iCloud to resolve calendar issues.

Any help is appreciate…John


#2

I was in the same situation. A search for “reconnect network drives Windows 10” brought up pages with various approaches to getting around this ‘feature’ of Win10. I found/chose a batch file “netdrives.bat” which I dropped into my startup folder. At startup it runs through all possible drives A: to Z: and finds your mapped drives then forces a re-connection for each one. A bit clunky and if it was important to me I’d find a more elegant solution but this works for my needs.


#3

Have you got the drives set to sleep? Check the energy saving section in the general tab of the settings menu on the dashboard.

If the drives are asleep when you open explorer then there won’t be a connection until you try and access them, which will wake and reconnect them.


#4

In my case I’ve always had the ‘drive sleep’ option under energy saving disabled. The “failed to reconnect drives” problem in Win10 networking was I believe related to the release of Windows 10 Version 1809. It was (well still is really) definitely a Windows problem for me.