MyCloud issues

Hi sorry if this has already been asked, i have tried to find it without success.

2 days ago i purchased the 2TB mycloud. i managed to get it up and running and started a back up, then went to bed. in the morning i could not access mycloud. my computer had rebooted (I assume updates did it).

Mycloud is connected to my router and is on my wireless network at home. i have not set it up yet to access from elsewhere. i have updated all firmware (when i did all the installation etc) I have rebooted the router and the mycloud and still i can not access the mycloud?

when i run the windows dianostic on internet explore cant open the page, it sats  the remote device or resourcewon’t accept the connection???

can anyone help please?

Do you use DCHP or Static IP’s on for your MyCloud?

Have you checked your router to see if the IP has changed on your MyCloud?

Can you ping your MyCloud?

Have you tried a  reset?

This is from the user manual:

Resetting with Power On
If you have set a password or a static IP address on the WD My Cloud dashboard and have forgotten it, pressing the reset button while the device is powered up resets the password to the default value of none and to default IP settings. The default IP setting is DHCP. Resetting does not erase your files. Follow the instructions below to reset the device using the reset button:

  1. With the device powered on, insert a paper clip or narrow-tipped pen into the reset button slot on the back of the unit:
  2. Press and hold down the reset button for four seconds. The device reboots (this may take up to three minutes).


thank you for the reply, however not sure what DCHP is? my broadband is with sky. i have put my sky router ip in and i see the mycloud  as cabled in the network devices.

How do i find the ip for mycloud if it has changed?

How do i ping Mycloud?

I have tried a reset and nothin happened.

I can not get the dashboard up.

I really appreciate your time helping me, thank you

Do you know your routers IP?  Some like, I am not familar with “Sky” ISP. The router should also ask for a Username and Password. I would “Google” Sky ISP and see what is out there.

In your router there should be a “Local IP” tab that the router has assigned every device in your network. Again this is specific to the make and type of router. Your MyCloud should be listed in that table.

To “Ping” you need to know the IP of the device you are pinging … so not knowing the IP is no help at this time.

You can open a “CMD” prompt and type in arp -a . That will give you IP’s and MAC’s but no names. Note that it will also list any machines you are connected to on the internet at that time, so don’t freak out is you see an IP listed that you don’t recognize.

Did you use the WD MyCloud Setup program when you first installed your MyCloud?

1 Like

well blow me its just sudden reappeared , having done NOTHING! and the control panel has come back??? not sure what happened but it was over 24 hours off. thank you for now. i will look into the things you have mentioned in case it goes again :smileyvery-happy:

If you have uploaded a lot of data to your MyCloud, especially media data, then what has happened was that your MyCloud was busy indexing that data … if you check your Dashboard it should say “Idle” on the “Content Scan” in the first page of the Dashboard. :slight_smile:

when i launch mc_windows_setup.exe when arrive to find wdmycloud, appair the icon and when i click next open a windows that say that cpontrol if it’s all right . when it’s finish remain so.