MyCloud isn't recognized on new router


#1

Hello,

Recently I bought a new router for the house (the same brand as the previous one, Asus). However when I connect my WD MyCloud to it, the router doesn’t detect the MyCloud.

Initially the Mycloud was on Static IP with an IP I set it (for clarification it is within the accepted IP range of both routers). I connected it to the new router but it doesn’t want to detect it. I then used my old router to connect my desktop and MyCloud, was able to connect like normal again. I also changed the network setting of the MyCloud to DHCP in case the static IP was causing the issue. That did not work either.

I also tried using the WD Discovery program in order to detect it and it wasn’t able to. In addition, the Admin page of the new router also wasn’t able to recognize the router whereas it was visible whenever I connect it to the new router.

A few things I know:

  • The local IP and Subnet Mask of both routers are the same.

  • On first attempt to connect the new router, the MyCloud had a static IP that I used with the old router. Trying to connect to this IP via a browser doesn’t work despite it being unassigned.

  • Currently the router is on DHCP after I reconfigured so it should be trying to get itself a new IP address from the new router and there are plenty available. But the Admin page of the new router doesn’t even recognize it regardless of whether it was configured with a static IP or DHCP.

  • It seems to work on the old router when I connect it back (with normal file access and all) but it doesn’t want to connect to the new router. Thus, the Ethernet cable connecting the MyCloud and the new router shouldn’t be an issue.

  • Whenever I reconnect the MyCloud to the new router, the MyCloud’s LED blinks white for awhile before it turns blue. This is normal whenever I on it again or reconnect it to something. What is weird here is that it turned “blue” at all which usually means that it found and recognize the network. So it seems that the MyCloud seemed to have recognize the new router…but the new router doesn’t recognize the MyCloud.

  • Turning it off and on again doesn’t work. I’ve also slept on it and left it connected to the new router network for around 8 hours, in case it gets recognized but no dice.

  • Internet on the new router is working fine as is the connection to my desktop. and other devices.

  • Both routers use the same SSID and password. Not sure whether it’s relevent but just mentioning it anyway. Router is connected to MyCloud via Ethernet.

  • My desktop runs Windows 8.1 but since this issue seems to be network wide I don’t think it’s relevent.

  • Both old and new routers are Asus and use the same UI interface on the Admin page so it would be easy to compare and contrast the settings if needed.

This problem is a bit worrying since I’ve spent quite a bit of money in the new router and my MyCloud is pretty important to me.

Any help and advice would be appreciated. I’m really hoping to find a solution. Thanks.


My Cloud does not detect network cable + blinking white light
Problem with WD My Cloud
#2

sounds like you covered at least most the posibilities

did you reboot the mycloud while it is connected to the new router?

what are the LEDs by the Ethernet cable on the mycloud doing?

on the old router was the static IP set in the mycloud? or was it reserved in the router?

does the status screen in the new router show all the other devices? any “extra” devices?

you may need to contact WD support


#3

hi. were you ever able to resolve this issue? i couldn’t have described the problem any better than you did…i have the exact same issue and have tried the exact same measures (except IP change to static), to no avail.

access on my old AT&T router remains perfect. also, i can plug the drive directly into ethernet port on a network laptop and it will be recognized and assigned an IP (assumedly, by the laptop, as the address doesn’t follow the router IP format I manually set).

but, plug it into my new AT&T router – which successfully connects to the Internet and other home network devices, assigning them all a manually configured set of since “fixed” DHCP router generated IPs – and I get nothing. not even activity LEDs at ports. they just do not see each other and will not engage in the DHCP process.

frustrating. and the Net is full of similar issues with NO resolutions that I’ve heard of that are as easy as it should be for plug-n-play devices. doesn’t even sound like WD tech support is getting it…I haven’t seen anyone who’s had any success there either, so I’m reluctant to even bother.

anywho, if you have any further feedback, that would be great…

to me this all seems like DHCP / IP related issues…how to overcome them is the trick, i suppose…


#4

Some are having trouble with the newer AT&T Uverse routers. The workaround at the moment until AT&T pushes new firmware to their routers to fix the issue (if possible) is to put a switch or hub in between the AT&T router and the My Cloud. See the following threads for further discussion.

https://community.wd.com/t/cant-connect-my-cloud-using-att-uverse-1gig-fiber-service/140412

https://community.wd.com/t/cant-connect-to-u-verse-help/150157


#5

Thanks for your post.