MyCloud intermitted connection and simply disappears from network

Good day,

I purchased the MyCloud drive a few months ago. From the get go the SmartWare continuous backup is extremely slow and never shows you why it stopped etc. Tried numerous suggestions with no joy… So after not using it for a few months, I started using it again.

My problem now is it just ‘disappears’ from the network. While it’s busy with a backup it just stops and disappears. Have to restart every time in order to find and start smartware again.

SmartWare and firmware is always up to date. The router assigns a static IP to the drive (linked to mac address), the drive itself is also set to use the same static IP. It is also linked to the same network group. The wireless is also disabled and the laptops access it via ethernet. Network is also working fine - did a simple tests by copying large files from one machine to another without any problem.

Does anyone perhaps know what else I can check or do to resolve this annoying issue? Could it be that the drive becomes too hot? It is however ventilated.

Look forward to your response, thanks.

Does it disappear from only one computer or multiple computers? What operating system or systems does it disappear from?

Hello Bennor, thanks for the response. It’s two laptops - one runs Win 7 pro and other Win 8.1 pro. It disappears from both. If you look at the smartware home tab the drive disappears completely and maybe show up again but disappears again. Also unable to access via browser. Only way to get it back is restart the laptops

Hi @Dawie_Hanekom

Please explain this scenario. if you have used a Static Lease inside your router, the My Cloud has to be set to DHCP, not Static. This issue sounds (again) like a misconfigured IP setup.

Hello Joerg, thanks for reply. Having the drive on DHCP causes issues and can not be accessed. How come all of the solutions online advises, that one should ensure that the drive is set to use static ip instead of DHCP?

Further more I use to have it the other way around - by only setting the drive to static and assigning it a static ip and keeping the router on DHCP. It had the same problem, that’s the reason why I placed a static lease inside the router and drive itself. Still make no difference or am I doing something wrong?

There are two ways to set a Static IP on the My Cloud. The first way (and the best way) is to access the router/gateway administration page and reserve a specific IP address within the router/gateway’s DHCP Server section. On the My Cloud Dashboard, one would access the Dashboard > Settings > Network > Network Services > Network Mode = DHCP. This way the local network router/gateway will always assign the same IP address to the My Cloud.

The other way is to access the My Cloud Dashboard > Settings > Network > Network Services > Network Mode then click on Static. At which point you will see a window appear (after notice message) where you input the following fields:
IP Address
Netmask
Gateway
DNS Server 1
DNS Server 2
DNS Server 3

It is important that one input an IP Address that while is in the same IP Address subnet block as that used by the router/gateway’s DHCP Server is outside of the block the DHCP Server hands out to DHCP clients on the local network. This will avoid any potential IP Address conflicts. Next ensure the Netmask is correct (same as that used by the router/gateway DHCP Server. Next, set the Gateway to the same local network IP Address as the router/gateway. Often people set this value to the wrong IP Address and it causes problems. Next, fill in the values for DNS Server 1, 2, and 3. Often people use the same DNS Servers as those used by their router/gateway, or one can input the local network IP Address used by the router/gateway (same as Gateway value), or one can use Public DNS Server addresses (http://pcsupport.about.com/od/tipstricks/a/free-public-dns-servers.htm).

My suggestion is always to leave the MyCloud setting as DHCP, and use the router configuration to set DHCP infinite lease for it, once an address has been negotiated. It’s less painful than having to set static address on the MyCloud, and DNS addresses, subnet masks, etc.

I use this approach for most of my home devices.

2 Likes

What router do you have? Is it 802.11n or 802.11ac etc? How is everything connected on your network?

cat0w
USA

Hi all, thank you for feedback. I changed the settings back they way it was, as you suggested. In the router I linked the MyCloud drive mac address to a static IP. In the MyCloud console I changed it to DHCP. I can see the drive on the network, but the settings does not seem to have made a difference.

As soon as the continuous backup starts via SmartWare it continues very slowly and after a short while the drive disappears from SmartWare.

Think it might be the smartware software (it is however the latest version) or could it perhaps be the drive that becomes too hot and then disconnects itself?

Below some screenshots showing the settings:

Huawei B593s-601 LTE Router using 802.11b/g/n

MyCloud Console changed to DHCP and picking up the assigned static IP by the router

Can see the drive on the network

I have never used static IP, I have over 30 devices that can (or are) connected to my network and they ALL work just fine. I never advise to use a static IP, instead I advise to fix the problem.

Do you know how to refresh File Explorer screen to see devices that have disappeared from Network? I often have devices disappear, and it is a “Windows thing” not a real problem with anything else.

In upper right of screen area, there is a refresh icon; likely a curved arrow or opposing arrows. Click on what you want to refresh (Network in his case) click on the refresh arrow, and devices reappear. If they don’t, then something else is amiss.

Restarting the MyCloud can cause trouble, since it often triggers a media scan and picture thumbnailing process. These are very CPU intensive, and may be the cause of your device disappearing, or not responding when you start a Smartware backup. Do you only have this trouble with smartware? Is it still accessible via Windows file explorer? You could try leaving it for a couple of days after a reset, to let the tasks complete, and then try smartware.

Or it could just be that smartware, like much WD software, is a bit rubbish…

Have you tried uninstalling then reinstalling the Smartware software?

Thanks - I mostly just restart the laptops in order for smartware to pickup the drive or allow me to access the drive dashboard via browser. Only restart the drive when I have to. When it disappears from smartware I try to immediately access it via browser dashboard, but also unreachable.

Yes, I’ve reinstalled once or twice

Hi All,

Some further feedback. Today it seems slightly better after I did the following:

  • List item I moved the drive to an area that is more open

  • List item After logging into the drive’s dashboard I waited until the scan finished and then started SmartWare continuous backup

When I looked after 4,5 hours it is still connected to the drive. Previously it lasted a few minutes. During the past 4,5 hours it transferred about 3882 files with a total size of 15,77GB. Currently it is moving extremely slow.

Now another issue WDSync cannot find the drive. When I tried to remove and re-add the devise it pics up the devise, but bombs out on the configuration * sigh *

I’m afraid the small victory was short-lived… After about 6 hours running the continuous backup, SmartWare just looses the drive. During the 6 hours it only backed-up 15.89GB.

Cannot access the dashboard via browser. If you hover your mouse over the SmartWare icon it shows the % used as zero and temperature unknown.

You can however manually browse to the drive and folders (access it) via windows file explorer.

Personally I still think it is software related or the drive becomes to hot causing the software to stop…

FreeFileSync

Just saying…