MyCloud Home stuck in reboot loop (every few minutes)

Hi,
I’ve been using a MyCloud Home for a few years, and suddenly it stopped working a few months ago. I’ve tried rebooting it, resetting it, and everything in between. All that happens is that when I plug it in, it boots up and then after about ~5 minutes, it reboots (light goes out and I can hear a sound when it does). In the meantime, it’s not even detected by the mobile app/ web page.

I don’t even see the white light pulsing or anything at all, just the normal white light. I’ve tried all the pinhole options (holding for a few seconds, holding for 30, holding for 60 seconds). I also finally detached the device from my account today, and that hasn’t helped either. Haven’t bothered trying to locate it manually, as it reboots every few minutes, so I don’t know how it would be functional anyway.

Tried everything I could think of and option I could find online in the last few months, and nothing has helped. Is it bricked?

Thanks in advance.

The My Cloud Home device is different than the My Cloud line of devices. If you have a My Cloud Home device see the dedicated subforum for that device where users more familiar with it may be able to help.

My Cloud Home
https://community.wd.com/c/home-cloud-storage/my-cloud-home/229