MyCloud Home - Have I bought the wrong device?

I have (or rather I had) a 4 GB MyCloud that I bought back in 2014. I use it as a set of shared network drives, and also as a streaming device. Recently it started going wrong so I decided go replace it. Looking at your shop on the web, I could not find a plain “My Cloud” so I presumed that it was now called “My Cloud Home”.

Now it has arrived and I have tried to set it up, it seems to be something different altogether. I cannot see any way to set up network shares on it, the way I used to. If I try to access it by IP address, my browser just sees the message “{“key”:“notFound”,“message”:“Not Found”}”

Have I bought the wrong device? What should I have bought to replace my old “My Cloud” device?

First, there is a dedicated subforum for the My Cloud Home.

My Cloud Home

This subforum (My Cloud OS 5 Personal & Network Attached Storage > My Cloud) is for discussion related to the OS5 firmware which the My Cloud Home does not support.

The My Cloud Home does not support the My Cloud Dashboard if that is what you were trying to find or access with your web browser.

If you haven’t done so already, see the WD Support page for the My Cloud Home which has information on how to setup and use the My Cloud Home device.

My Cloud Home
https://support-en.wd.com/app/products/product-detail/p/1369

The My Cloud Home is not a replacement for the discontinued single bay My Cloud device. Many have found out the hard way that the My Cloud Home is a completely different device with different (some say fewer) options and features than the single bay My Cloud. The My Cloud Home really isn’t an NAS in the traditional sense.

Only you can answer if you bought the wrong device based on what you wanted and were looking for.

If you want a single bay NAS device you will likely have to look to other manufacturers, or buy a refurbished / used discontinued single bay My Cloud model from somewhere, or build your own NAS. Plenty of DIY guides out there for building your own NAS. The general trend these days for low end NAS devices is multi bay models. For the WD products look to the EX2 Ultra which seems to now be the entry level traditional NAS device for the WD NAS line.

Back when I used to shop in stores; I took a look at the “box” for the mycloud home.

The box is VERY misleading. It makes you THINK this is a proper NAS; but it is not except in the broadest sense. I believe it requires internet access to function? I would consider that disqualifying off the bat.

Bennor rightfully points out that buying a refurbished Single Bay MyCloud is an option. You can. . but I would not. The hardware is relatively slow by today’s standards. . . and the software is a serious issue. (OS/3 software is old; OS/5. . . which is new. . .has issues).

The EX2 ultra is a nice two bay NAS. . I have one. . . but I would be hesitant to buy one new today given the software options of “OS3” or “OS5”.

Thanks for your reply. I do understand that this sub-forum is not for MyCloud Home, but MyCloud Home does not seem to fit what I wanted from it, which is why I posted here. I just had a long chat with WD support, and I am returning the MyCloud Home.

Unfortunately, the EX2 Ultra looks quite expensive … more than double what I paid for my old server back in 2014. I just hope I can find a solution soon.

Thanks again.

Thank you NAS_user … useful information. My old server (2014) was OS3, and it was OK until the dashboard stopped being able to tell the difference between audio files, video files, and others. And it went downhill from there on. I have not tried a factory reset yet, in the hope I can recover some of the data.

I must do some reading on the forum and see what people don’t like about OS5 vs. OS3.

Thanks again for your guidance.

The first troubleshooting step with a single bay My Cloud that is having issues is perform a 40 second reset. No user data is lost performing a 40 second reset.

How to Reset a My Cloud (single bay) Device
https://support-en.wd.com/app/answers/detail/a_id/24022

If the single bay My Cloud hard drive is failing, given the age of the devices this isn’t an uncommon issue these days. One can always replace the hard drive with a new one. Plenty of discussion on “unbricking” a new hard drive to work in a single bay My Cloud enclosure. Note however that because there are two versions of the single bay My Cloud, first gen v4.x firmware and second gen v2.x firmware, the method to unbrick differs slightly between the two versions.

Not many single bay NAS models these days. Synogloy still makes a few models as does Buffalo. Typically though one will likely pay more than they did for a single bay My Cloud. Several causes for this, one is prices change given age of the old single bay My Cloud.

Not sure that the OP wants to spend the money on a “product”, just to load it with custom firmware :wink:

Thank you Bennor, that gives me a useful way forward. The old server is now on my workbench flashing its orange light, presumably getting to grips with the files on the disk before presenting itself to the world. I shall post back when the blue light comes on solid.

I shall consider the EX2, but I have seen a youtube review suggesting the EX2100 instead. I guess some of the extra cost is because it uses WD Red disks for 24/7 operation, and of course twice as much disk space so you can RAID it. Looking at today’s prices, it looks like I got a real bargain back in 2014 at 169 Euros for 4 TB.

Update: I tried the 40 second reset. It worked in the sense that it cleared down the user accounts, permissions, etc, but left the data intact. At least I can now get at the data, but it is still misbehaving. I shall start a new thread about the misbehavior to see if anyone can advise.

In my case, I can’t access it from my mac, but from my Iphone 12 I have no problem, because I have the app, why don’t they put that App for the mac in the apple store?

Cannot access what from your mac? A My Cloud? A My Cloud Home? What specific My Cloud device do you have, and what is the specific error message or issue are you experiencing on your Mac?

Note the My Cloud Home is a completely different device with different features and options than the My Cloud line.

Some have had luck accessing the local My Cloud using AFP rather than SMB in the Mac Finder. Example in Finder: afp://<mycloudname>.local.

For remote access to the My Cloud one is generally limited (on a Mac computer) to using the MyCloud.com web portal or the insecure FTP option. The multi bay My Cloud models may have additional methods of remote access that may require additional user configuration of either the My Cloud and or the local network router.

Who knows, could be Apple has such strict requirements (or third party app application validation process) for apps they host on the Apple Mac App Store that its easier/cheaper to not go through the process and instead host the Mac app on the WD site. Really though, its not difficult or hard to simply go to the WD Support website and download the Mac app for either the My Cloud or My Cloud Home devices.

https://support-en.wd.com/