MyCloud Home Desktop App not installing correctly


#1

Help

iMac 64 bit.
OSX El Capitan version 10.11.6 (all updates applied)
Cycloid Home drive plugged directly into my router.
Internet connection available - no firewall in operation.

Setup process completed on my iMac - ‘All Done’ page displayed. Get Desktop App actioned. When opened, the app does nothing but show a blue panel where there should be information and links.

Has anyone ever seen this before and, if so, what am I doing wrong?


#2

Hi cmorris242,

You can uninstall and reinstall the latest version of WD Discovery for My Cloud Home device to use as a desktop app on computer.


#3

Hi Brandon.P

Thanks for your response but I’ve already tried that. I’ve even uninstalled all WD apps from my Macbook Air & iMac then returned the MyCloud Home to factory settings and started all over again - absolutely no difference! The desktop app installs and works on the MacBook Air but only appears to install on the iMac with no functionality behind the app.

It’s important for me to have the desktop app on the iMac because I’d like to keep a synchronised copy of my photo library (270GB which is located on the iMac) with the MyCloud Home, I think that this would ensure that copying and synchronising happens across the LAN and not via the Internet.

I can access MCH via Safari browser on the iMac but it’s not sustainable given the volumes of data that I need to transfer - plus this method blocks me from moving that size of file via a browser.

Any ideas?


#4

Hi cmorris242,

You should try contacting WD’s Technical Support about this.

To Create a Support Case:

To Contact WD for Technical Support