MyCloud got full (4.1kb free) and cannot access files or delete via app,FTP,SSH!

MyCloud has only 4.1kb free and it is turnd useless.

Cannot be accessed via Windows. The app can only browse up to the Folders. Cannot go deeper.

I cannot delete using the app, FTP (getting directory list takes forever), SSH (rm -rf command never completes)

So I have almost a brick!

Obviously it is some clumsy written firmware than needs some minimum free space to operate…

Hello Pyjamarama,

Have you tried deleting the files from MyCloud.com

http://files.mycloud.com/

I ran into the very same issue - zero bytes free on my WDMC. If you can access your WDMC via ssh, try this - assuming the file you want to delete is file.xyz:

> file.xyz

this deletes just the contents of the file. Now you should have some space left again. Start with small files first. Worked for me.

I think your post has been corrupted by the forum’s formatting interpreter.

That doesn’t look like any linux command I recognise.

Try editing your post, using the ‘preformatted text’ formatting: </>

from the context, it looks like he is using echo with redirection. eg

echo "" > file.xyz

this would over-write the file with a null content. This is different from using echo to append, which uses two greaterthan symbols like this

echo "" >> file.xyz

Yes, it looked like a redirection. I just wasn’t sure what he was suggesting be redirected. Your echo would work fine.

I’m guessing rm can’t run if there’s no disk space free, since that’s the tool I’d normally turn to to retrieve disk space…

In my browser it shows correctly, it’s > file.xyz or, formatted as html, > file.xyz - this will empty an existing file. It’s basically the same as echo “” > file.xyz. At least in bash you can skip the echo “” part, it’s valid.