Mycloud gen 2 4tb upgrade problems

Alright, unfortunately I am very quickly becoming an expert in this mycloud stuff out of necessity. I haven’t even touched a Linux distro until a week ago. As usual, everything that could have gone wrong, has.

Following Fox_Exe’s instructions (and rewriting a majority of it for better clarity), I cannot get my mycloud to fetch an IP from the router in order to utilize telnet with the given steps to create the USB. I have long since abandoned this method. I finally succeeded in using the ‘alternate’ way as described in Fox_Exe’s instuctions with barely a pyrrhic success. Using Linux mint, I was able to sort my way through the partitioning commands (I’ve done this around 40 times now on my poor brand new 8TB HDD) and got the mycloud to pull an IP from my router and I was able to access the “safe mode” screen. YAY!.. right? No (took at least 2 months to research my way to this point)

Here is my problem now. I can select the firmware to load to the mycloud on the “safe mode” screen, obviously I choose 2.xx firmware. Problem is, no matter what firmware version I choose, the mycloud light switches from red flashing initially, to blue flashing for a moment and straight to solid red and stays there; all the while the pinwheel of progress stays at 0%. I have only ever been able to get the mycloud to load an inputted firmware once from this screen when I was unbricking the original 4TB HDD, even that was a tedious process that took me about 14 tries over several weeks.

Am I missing something here? I have tried everything from switching around the order in how I create the partitions, formatting all partitions to ext4, changing the name of the boot directory for recovery, using mycloud image files, low level formatting, and resorting back to plugging in the recovery USB, waiting for the red-yellow flashing light, and crossing my fingers that the mycloud can finally pull an IP for me to use. At this point, I don’t know how much life my 8TB HDD has left in it.

I have waited around a year to create a forum post as I was confident something so simple surely couldn’t give me such a hard time. I have been broken, and now am calling for help.

I must have searched every forum post about all the issues and techniques people have gone through to get these things working again (especially the main two about 0% problems), none of which seem to answer questions. Many posts have said they are making detailed instructions for an unbrick of these devices. Since I have been struggling through all the possible problems known to man, I feel I need to share my experience and post a true, elaborate and comprehensive tutorial outlining all the possible problems one may encounter when unbricking specifically the gen 2, and all the reasons for all the inputted commands. (AFTER I FIX THIS FREAKING THING.)

TL;DR
Any input as to why I am getting stuck on a 0% safemode screen would be great! (And yes, the 4 and 40 second resets do nothing. Those don’t ever seem to be operational when you need them anyway.)

Bennor, I have seen you as one of the main people heading these types of questions, help a brother out?

Are you following the Fox_exe directions for unbricking a second gen single bay My Cloud exactly? Do not change or modify the steps and do not modify or change the partition size values. The partitions need to be created in a specific order and to a specific size/capacity. Make sure to use the v2.x firmware from the WD website.

As a trouble shooting step, use Mac or Windows and initialize the hard drive to GPT not MBR and create a single large partition using the full space of the hard drive and format it to NTFS. Then use Linux to remove the existing hard drive partitions and reformat/partition per the Fox_exe directions. The following link has some past discussion on getting an 8TB drive to work in a 2nd gen single bay enclosure.

Yes, followed it to a T (telnet directions seem lacking as he pretty much just barely mentions it, then proceeds to use it for the remaining steps). Unfortunately I have tried this and ended up trying different permutations of the same steps to see if I could get a different result. It didn’t seem to help initializing as GPT in Windows before moving over to the Linux distro so I didn’t bother switching to my Windows system that takes 15 min to boot every time. I have been deleting all partitions, creating one large partition of NTFS, and deleting that one before each attempt, all within the Linux distro since. No dice as of yet.

I wonder if someone would be able to revive the telnet method? It seems like I have beaten this take the drive out, fiddle with it, format it, put new partitions on it, move two files over, and reinstall it onto the WD motherboard to death. I gotta think that if I can manage to figure out why my MyCloud isn’t pulling an IP, everything else would be a relatively simple matter. Any thoughts? I’ve remade the recovery USB several times, the MyCloud can go into the flashing yellow-red state every time which should be ready for a telnet connection, it just never pulls an IP from the router no matter what I try.

There isn’t some default IP I can use on the MyCloud that would allow me to interface with it by plugging the Ethernet cable directly into my computer, is there?

Does brand of router matter? Perhaps the types of devices already connected to the router preventing the MyCloud from pulling an IP?

As you can see there have been several variables I have yet to test, but without much evidence to suggest doing so would yeild a different result, I have restrained myself.

Unfortunately, I have religiously been scouring the forums. As result, I am very familiar with the link you provided, it has not aided me with anything as of yet.

Update, I am no longer able to access Fox_exe’s file repository. Looks as if he has taken it down due to the invasion of Ukraine and surrounding politics. He left us with this message.

"Now a whole world hates me just because i born in Russia…
The whole world is racist now.

Maybe i return all data when this ■■■■ is over…"

I don’t have access to the virgin file for the usbrecovery.tar.gz

Do you happen to have it?

Prayers for citizens of Russia who didn’t want this to happen.

https://www.dropbox.com/s/cwn4sednejan97c/usbrecovery.tar.gz?dl=0

I’ve decided to retry the directions with the link you provided once more, this time with a different HDD. I however, have a question first before I continue.

This step: “* Copy wdrecovery-files to sdX3: I used a USB stick to transfer them into the VM (attach USB stick to VM, mkdir and mount device to dir)”

It makes no mention of what directory that it needs to be in. Do I follow Fox_exe’s steps here, or can I simply open the partition on sda3 with a GUI window and drag and drop the files directly in? Also, with Fox_exe’s instructions, it seems you only place two files in this partition, but it sounds as if with this instruction it wants me to add all four files within the ‘boot’ directory of the flash drive I made. Is this true?

Probably not wise to mix directions, use one set of directions or the other. The [My Cloud Gen2] Using an 8TB HDD and Formatting Failure (Error Code: 600) directions do not indicate creating any directories. Looks like that person just copied the extracted usbrecovery.tar.gz boot folder and the four files within it to the SDX3 (EXT4) data partition.

This will likely be one of those times where one will have to try it and see if it works. If it doesn’t, try a different method or set of directions.