MyCloud (gen 1) not visible on w/ browser, but Android app shows device

Hello, I have a 1st-gen WD MyCloud 3TB running WDMyCloud v04.05.00-334 : Core F/W.

I have a account. If I access via my MacBook Air + Chrome, it ONLY shows my EX2Ultra device (on another network). If I access via my Android phone, BOTH my EX2Ultra and MyCloud 3TB shows and is browsable (i.e. everything works).

MyCloud 3TB is on the same local network as the MacBook + Chrome, but it never appears.

Finally, looking at the MyCloud 3TB Cloud Access dashboard, I see: Connection Status Connected (Relay connection established).

Very puzzled how it works for my Android phone, but not my web browser, which I assume are accessing the same data.

EDIT: FWIW, I also tried accessing via my MacBook using incognito mode, but no change.

Try using a web browser other than Chrome. Also as a troubleshooting step disable all web browser add-ons/extensions as some can cause problems with the web portal. Same goes for certain security/anti malware/anti virus software on the computer.

In extreme cases one’s DNS servers used by their ISP may cause problems accessing websites. The workaround is to assign public DNS servers to one’s computer.

Currently using Firefox on Windows 10, no problems access a first gen My Cloud remotely via the web portal.

I appreciate your help, but none of that is it.

My machines are all Macs, none of which are running any kind of security/anti-virus software.

I’ve tried both Chrome and Safari, the latter of which generates only this on login:


The server encountered an unexpected error which prevented it from completing your request. Please close this window and start the sign in process again.

Footer Logo

© 2015 Western Digital Technologies, Inc

… and, my office network is already using Google’s DNS (, so the ISP DNS issue isn’t at fault.

No, it’s WD’s crappy software.

I had no problem adding the WDMyCloud 3TB to both my Android phone and my iPad, using either the generated code method or the local discovery method.

And, I have no trouble browsing my remote-located EX2Ultra via or the apps on my phone or iPad.

With the iPad app, I deleted the app and started from scratch, where the app offers the opportunity to add a new WD device to your account. In all cases, is discovers the MyCloud, but then complains that the password I enter for my user account is incorrect, when trying to add the device. This leads me to believe that can’t communicate with the WDMyCloud in my office.

And, yet, the MyCloud reports a successful Relay Connection to