MyCloud - Fasr write, Slow Read


 I was trying everything (I think), still no luck…

 The problem is: on home network, with 1Gb router, on cat6 cables MyCloud can reach only 13-15MB/s transferring files (size doesn’t matter) to my desktop PC. Writing speed (back to MyCloud) is normal- around 50MB/s. So far I was trying:

  1. another PC with 1Gb ethernet card - the same result

  2. MyCloud connected direcly to PC   - the same result

  3. installing clean debian on MyCloud - the same result

  4. upgrading samba to samba4 (with/without tweaking) - the same result

  5. downgrading software to v.3             - the same result

  6. checking cables - on the same cables my MyBookLive reaches 70MB/s reading speed

  7. Full restore on MyCloud                     - the same result

Is it possible that official update (v.4) install some sort of firmware into MyCloud (does it has a flashrom?)  ? Maybe this update changing share speed for good?

Can someone help me resolve this problem?

the only additional test i can think of is to boot your PC into safe mode with networking and test again.

If you truly tried everything here I think you need to contact WD support as it seems to be a hardware issue. I would probably not mention step 2&3