MyCloud EX2100 RAID degraded

Hi everyone, I’m newbie here. I have MyCloud EX2100 8TB and this is my first NAS device. I have started to use it few days ago and total operation time is between 20 to 30 hours as I can guess. I bought it because I believe in the reliability of WD products, but it already started to give me problems.

Today, when I powered on the device one of the indicators lights (in bay 2) started to glow in red instead of usual blue color. So I have immediately open the web based dashboard and presented with the error saying ‘Raid degraded’. Since then I have tried to browse through the internet to find a solution without any luck.

I don’t believe there are problem in the WD Red HD in bay 2 because I have only used it around 30 hours and every disk tests and diagnostics doesn’t indicate any drive failures. Every test states drive health is ‘good’.
I have attached screenshots also. Can anybody help me to resolve this issue because I’m totally new to this subject?

I have tried to manually build the RAID from here. It pass the drive test step also but after that also problem isn’t get resolved.

(firmware version 2.11.133)


Do you have much user data on the NAS as yet ? If so, it might be worth backing it up, as a precaution.

What I would suggest doing, would be to remove the drive that has come up RED and reseat it into the NAS. It’s possible that it has not quite fully connected or perhaps been bumped and gotten a bit loose. After this is done, then you could try and see if the RAID rebuild will then work.

If you had SSH access to the NAS, you might be able to view more details on the status of the RAID array similar to the following:

root@WDMyCloudEX4100 /proc # cat mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4]
md1 : active raid1 sda2[0] sdb2[1]
      2926070648 blocks super 1.0 [2/2] [UU]
      bitmap: 2/2 pages [64KB], 131072KB chunk

md0 : active raid1 sdb1[1] sda1[0]
      2097088 blocks [4/2] [UU__]
      bitmap: 1/16 pages [32KB], 8KB chunk

If there is a problem it would quickly show you here which devices have the problem. The other thing that might be useful with SSH enabled is to view the “messages” file as it might give details on why it won’t re-sync.

Have you also logged a ticket with WD support to see if they can assist ?



1 Like

Hi JediNite, Thank you for your help :slight_smile:. I had removed and re-inserted problematic drive from drive bay and then tried to rebuild RAID several times as you suggested, but every time the result was same.

The problem is solved now

The problem was now solved. If anyone else face similar problem this is basically what I did.

  1. Removed the drive from NAS and connected it to PC as an internal drive

  2. Downloaded and installed WD Data LifeGuard Diagnostic for Windows from WD support and download section

  3. Scanned the drive with Data Lifeguard Diagnostic and ran ‘Quick Test’ and ‘Extended Test’

    The extended test took whopping 12 hours to complete the task and it detected few recoverable bad sectors on the disk (I still don’t have how it got bad sectors because it only used 20 -30 hours :thinking:). The tool repaired the corrupted sectors.

4 Inserted it back to my EX2100 and powered it on… hooray the indicator LED turns to blue. It took another few minutes to rebuild the RAID. But everything works fine now.

1 Like

Hi Hasitha
I have got EXACTLY the same problem here with one of my EX4100 after having upgraded from OS3 to OS5.

I just started the WD Data Lifeguard Diagnostics on it …

  • the quick test notifies of a read error after a few seconds…
  • I started the extended test, which has run now since 5 minutes without problem …