MyCloud EX2 Ultra OS 5 - IP address redirect

Hello, I’m the owner of an EX2 Ultra NAS and I’ve recently updated to MyCloud OS 5 and I had some problems (the version now is 5.05.111)…

Maybe I’m stupid and I don’t know how to my NAS do this, but when I insert the IP address of my NAS in a common browser (safari) this redirect me from “10.0.0.XXX” to “https://device-local-ZZZZ(some numbers)”, this slows down the loading process of the page and I can’t access to the web interface directly or to the other applications of the NAS inserting directly the IP address of the NAS with the port (ex. “10.0.0.XXX:YYYY”) because the NAS always redirect to the URL wrote above…

Can you help me to understand why this happens and maybe how to fix it to and use always the IP address of the NAS with “10.0.0.XXX” to access it and its applications??

Thanks in advance

@stemac02 More information about the redirect is located here.

1 Like

You are not the only person asking about this. . . .


Hey, when can we expect you to give us an option to disable this? A lot of us don’t want it and in fact it breaks a lot of functionality of the device. What’s the timeline for a firmware release that allows us to disable this feature we don’t want?

1 Like

Oh okay thank you for the answer… but I share with @OS5_Is_Terrible (you’re name makes me laughs in this topic focused on OS 5 ahahah), can we expect and option on the next update to disable this function?? Because from also @NAS_user I saw that other people don’t like this features and breaks some functionality of the NAS…

1 Like

I linked a solution to this using uBlock Origin over in the # Disable HTTPS redirect thread, but here it is again in this thread for your attention :slight_smile:

I too found a way to block this using uBlock Origin, huzzah!

You must have advanced mode turned on in the extension settings and then when you navigate to YourIP for your NAS you configure the settings like this:

Once this is set, using direct links like MyIP/apps/transmission/web/transmission.html works without having to go through the admin panel and navigating to the app configure first too! Great success!

1 Like

@stemac02 my username is the reason I am here, to fight the evils of WD and the perilous pitfalls of OS5!! Grrr!

1 Like

But unfortunately I’m using safari on my iPhone and I can’t install the extension :slightly_frowning_face: … Yes it’s a way to use the IP address of the NAS but not a stable solution for all the devices… Thanks also for the update about this topic… If you’ll discover something new tell it to me