MyCloud EX2 Ultra - Dateien fehlen nach Linux-Nutzung

Hi,
ich nutze die WD My Cloud seit kurzem unter Linux und Windows.

Jetzt musste ich über Samba in Windows feststellen, dass dort sehr viele Dateien nicht mehr angezeigt werden. Die Festplatte zeigt jedoch weiterhin 90% belegt an, die Files sollten theoretisch also noch vorhanden sind.

Wie gehe ich am Besten vor, ohne die Dateien zu verlieren? SSH einloggen und Rechte manuell setzen?

Die Cloud mal ein und ausschalten damit neu indiziert wird hilft nicht?

Leider nicht. Aber ich habe gerade mal via SSH nachgeschaut im Ordner /mnt/HD/HD_a2/ und bin etwas beruhigt die Dateien wenigstens dort noch zu sehen.

Das kuriose: Die Files welche ich sehen kann, haben teilweise root:root Rechte (wohl die in Linux erstellen Files/Ordner). Die Files mit dem normalen User kann ich komischerweise nicht alle sehen, obwohl ich genau mit dem User in Samba eingeloggt bin.

Ich bin ratlos. Allen Files root:root Rechte geben scheint mir irgendwie auch nicht als die richtige Lösung.

Könnte es am chmod der Files liegen? Die meisten Ordner/Files haben 777.

Sorry da bin ich überfragt, mit Linux kenne ich mich sehr sehr wenig aus.

Hast du vieleicht Sonderzeichen in den Verzeichniss- / Pfadnamen?
Damit gibt es bei Linux und bei Windows schon mal Probleme, wie ich festgestellt habe.
Z.B. das Tilde Zeichen? (~) das gibt Probleme mit Samba.
Edit 2: Alte, gekürzte DOS-Namen mit Tilde vs. Langnamen.

Wie du die Verzeichnisse in Linux und in Windows “fest” verbinden kannst, steht im 1. Teil zur Heimnetzwerktechnik.
Download Paket: Heimnetzwerktechnik für den Heimanwender

Hi Leute,
ich muss vergessen haben zu antworten. Ich habe das Problem aufdecken können. Es ist so viel simpler wie man denken mag:

Die Dateien wurden auf Versteckt gesetzt in Linux, und waren dementsprechend auf meinem Windows-System nicht mehr zu sehen. Nachdem ich in Windows “Versteckte Dateien anzeigen” aktiviert hatte, waren sie wieder alle da. Blöder Anfängerfehler, entschuldigt :wink: