MyCloud EX2 Ultra Cover Art not displaying Issues with MP3 Files

Device: MyCloud EX2 Ultra
Firmware: 2.31.183

I’ve read lots of posts about cover art not showing, but none of these seem to solve my problem.

I’m storing MP3 files in Public/Shared Music. Sometimes the cover art shows (its embedded into the image, and other times not).

In general Podcasts downloaded from the BBC seem to show with cover art straight away, and my own files seem random.

For example:

The odd thing is, if I go in through another application and via UPnP I see the cover art perfectly:

For example this is VLC on Android:

Also if I go to the web front-end for Twonky all seems to appear fine:

Can anyone help me find out what the problem is and how to solve it?

Thank you in advance

The problem lies with how the MyCloud web portal or it’s corresponding code within the My Cloud firmware is handling the MP3 files metadata tags. Assuming of course all the files with missing album covers are encoded for MP3.

Couple of suggestions. First, check the dedicated EX2 Series subforum to see if others with that device have experienced similar problems (if you haven’t already).

Second, try either reencoding the audio file with the missing album art to ensure it’s in MP3 format by checking what audio encoder was used on the MP3 file(s) that do show the album art. Could be a problem with the web portal not liking the audio encoder used to the create the media file.

Third, try using a different program to edit/create the metadata tags if you haven’t done so already. The free MP3Tag (https://www.mp3tag.de/en/) is one popular metadata tagging program as is Media Monkey (https://www.mediamonkey.com/).

Lastly, read through the unofficial Twonky FAQ if you haven’t done so already. There may be suggestions in there to help with your issue.

Thanks for the reply @Bennor

I will look on the EX2 subforum (I have also moved this post to that subforum). I used mp3tag on all the files (apart from the BBC one), and its odd that only one appears. You mentioned Twonky, but I’m not sure if you saw my screenshot as that displays the images perfectly so I don’t think it has anything to do with that.

@jonesypeter,

I just tried a few Podcasts from BBC site. Looks like the 128k mp3 download from BBC site doesn’t have cover art embedded but the 64k mp3 file does.

Contact the WD Support team directly if your mp3 all have cover art embedded.
https://support-en.wd.com/app/Contact_Us

Hi @jchen

Thanks for the reply. I think you got the wrong end of the stick. The BBC Podcast files are fine, its my other files not working.

I tried to log a support call as you suggested but just get this after filling in the form, and lost everything I had typed in! Is there an email address I can use?

Thanks