MyCloud EX2 not recoginized in Windows 7

Hi Experts!

I just got my EX2 but after downloading and running the setup software from y get a Windows message stating that no driver can be found for the device. I can still connect to the EX2 with a browser, create shares, etc. I am using W7 Home Premium SP1 in Spanish

I tried in a different PC with W7 Enterprise SP1 with the same result. However, in a third PC with W7 Home Premium in English  the device is recognized and the driver installed. It shows nicely in the Storage section of the Computer/Network window, with its own icon (not in the PC section, though)

The device driver used is  WD_MYCLOUDEX2_2_2_0.dll. I copied the file the the Windows/System32 folder in the other computers, but still it will not find the right drivers, even forcing the search to that folder.

Perhaps the W7 language has nothing to do with the device being recognized, but it seem a path worth exploring.

Any clue as to why is the device not recognized?

thanks in advance


The lack of a driver installation should not affect a network drive.

Try mapping the drive manually with the instructions bellow.

Mapping a Personal Cloud drive or WD NAS drive on a Windows PC

Thanks John,

I can map a drive letter o create a short-cut  to a share in the EX2, because I know the name of the device (CLOUD-VELETA), but it is not listed as one of the devices available in the network.

The EX2 doesn’t show in the PC area of the Computer/Network window, although it shows in the Storage (Almacenamiento)  section. I think this is a anomalous behaviour.

I have a My Book World also in the network that shows correctly in both areas (BACKUP-VELETA)

Any suggestions as to make it visible in the network?