Mycloud don't download nothing


My device is WD MYCLOUD 6TB with v04.05.00-320 : Core F/W .

I have no problem connecting with the wifi connection.

When i connect to device by WAN, i can enter via mobile app, wd login web and windows app desktop, i can see files and folders and update new files, but i CAN NOT DOWNLOAD or SHOW PHOTOS or something o_O’.

i try to shutdown wd, router, remove apps, restart router, wd and install apps and the result is the same…

i configure the router by upnp with the same error, and change to NAT table to mapping and the same result, i can enter and modify but no see the content…

i change the router, dissable IDS, firewall… and nothing change…

i don’t know if this error is consecuence to update firmware…

any solution? download firmware?? open any port? (80,443,+??)

I am very disappointed of the WD mycloud, I’m rethinking change to qnap o sysnology and put into the wd HD 6tb.

If i repeat the action to try to view some documents by wan… finally the cloud seems desconect wan acces and message “Drive offline XX is not accessible. Local documents are aviable” appear.

When i try to view some image or document don’t appear any error message, only seems to be load but nothing happen.

But only by WAN!!!, if connect by LAN i don’t have problems…

PD: sorry for my poor english level.

Are you connecting by using,


the same problem with iphone app or wd desktop (windows 10).

another strange thing is that when I connect for example on the web with the page that you comment and I enter a folder that there are images, I do not see the photo in small (thumbnail) but the round leaves that thinking but never loads the thumnail.

i redirect all ports from router to wd mycloud, except 32769 (UDP), 8080 (TCP) and 50805 (TCP) because my router say that this ports are for its maintanance…

i do more test connecting wan and :

  • with ios app i don’t view preview images.
  • with online acces i don’t view preview images but if i click in download image, sometimes this download…

i never connect by ssh and i never install nothing… mycloud is only autoupdate firmwares… i try to reconstruct bd buttom and nothing…

I am disappointed and tired of this product … and its support without answers …

Couple of suggestions, if you haven’t tried them already. Access the My Cloud Dashboard > Settings and set the Cloud Access option to manual and specify different ports than the default ports. Try using 8080 and 4443. Then configure port forwarding within the router to forward the two new ports to the My Cloud. It is also advisable to access the router and reserve an IP address for the My Cloud within the router’s DHCP section.

In certain cases disabling remote access through the My Cloud Dashboard > Settings section waiting five or ten minutes, then re-enabling remote access may fix certain remote access problems.

If you haven’t tried another computer or mobile device as a troubleshooting step, do so and see if the problem continues… Could be something particular to that one specific computer/mobile device is preventing files from being downloaded. Sometimes browser add-ons and third party firewall/security software may interfere with the web portal or downloading files in general.

Please note that this subforum is mostly a user-to-user support forum. Very few actual WD Support personal/staff monitor or reply to users. If you need actual WD Support, contact WD directly if you haven’t done so already.

–>Try using 8080 and 4443

I writed that 8080 port is for router maintenace and i cann’t redirect. Anyway i have configure in tis opcion 80 and 443, and ALL PORTS de router to WD mycloud ( except ports i wirted in other post )

now :

Wan -> 80 -> Router -> 80 -> my cloud
Wan -> 443 -> Router -> 443 -> my cloud

–> re-enabling remote access

i re-enabling, restard, shutdown and disconect cable… and nothing.

–> Contact Suport.

ok, i will do it.

i don’t believe this problem only afect me. I have Orange ISP and Orange Router.

–> If you haven’t tried another computer or mobile device as a troubleshooting step, do so and see if the problem continues…

I try connect by 3 diferents phones (2 iphone and 1 android bq) and 2 diferents computers ( ubuntu by firefox and w10 firefox and internet explorer )

i connect to mycloud, i can upload files and i see folders but don’t download nothing… :frowning: . if the folder have a lot of files seems don’t work too and i don’t see the contenct of the folder…


FINALLY i find the problem.

Orange ISP activate IPV6 ¬¬’

and now is not possible use NAT redirection, i must use PCP router config.

everything works fine until ORANGE isp change my dynamic ip .

more info :ÍA-Redirección-de-puertos-en-IPv6/m-p/539462#M33000