MyCloud Died?

Came back off holiday to find that our Mycloud drive was not connecting to our computers. I tried resetting it but just kept getting a solid red light on the front. Decided to leave it switched off for 24 hours but on turning it on again just get a flashing white LED and the sound that the drive is starting and stopping about once a second. Both network LEDs flash green at the same time.

Is this terminal? And if so is there any way to recover data from the drive - we have almost 10 years of photos and work stored. Only have access to Macs at the minute too…

Please help…

Thinking about it, it was fine until the latest firmware update…

It may be a faulty HDD. Or it may simply be a faulty PSU, unable to supply enough power to run the unit. See if you can find a replacement PSU (it’s a fairly standard 12V 2A ‘wall wart’ with a DC coax plug. Just take care with the plug polarity and centre conductor size.

It’s a SATA HDD, so can be plugged into any PC, and accessed using an extfs file system extension.

Not sure about Macs; maybe a powered USB caddy, but I don’t know about how to access the ext4 file system used for the user data partition.

Now is probably not a good time to mention backups…

1 Like

Thanks I’ll give it a try… Thought the whole point of the cloud drive was to backup stuff…

It’s only a backup if it’s a copy of a primary data store held on some other device (PC, phone, tablet, etc). If it’s the only data store you have, it’s not a backup; it’s the primary data store.

The single-bay MyCloud isn’t a redundant data store like an online cloud service is. There is no data redundancy, and no copy held on an online server somewhere.

If you have been using your MyCloud as a genuine backup device, then all your photos and documents are still safely stored on the primary data store; your PC, etc. Buy a new backup device, and backup your primary data store again.

1 Like

Further to this. i have now tried alternative power options but without luck. As a final resort I have put the drive into a SATA enclosure and it appears to be spinning however I cannot get it to appear on my laptop (MacBook air). Wondering if there is anything I need to do to make it visible (and therefore accessible)…

Hindsight is a wonderful thing…:cry:

You will need a utility to let you read linux ext3/ext4 file systems, which is what the MyCloud disk is formatted with.

You might try the free version of this tool, which has been successful in its Windows incarnation (as earlier link):

1 Like

no luck… It just doesn’t recognise that the drive is connected…:sob: