MyCloud connects to network but not accessible at ALL

I have a 6tb single bay that just stopped being accessible. It connects to my local network (through ATT UVerse router) and gets an IP address, solid blue light. BUT it is not accessible AT ALL. I’ve tried a browser pointed to the IP address and get a “connection timed out” error. I tried using the MyCloud desktop software and it just hung trying to connect. I did a “40 second” reset, and it again connected to my network, then I tried using the setup software, and it can’t find the drive. I’ve changed ports on my router, change the cable (all of which is irrelevant because it actually does connect to the network) and still no go.

Any ideas of what to do next?

I have 7 of these things, this is the newest. The other 6 have been functioning (in various locations) for YEARS.

Does it respond to pings?

No. “Request timed out” response.

There is a known issue with certain AT&T Uverse routers, one that has been well discussed in past threads that can be found using the forum search feature, magnifying glass icon upper right. WD Support even has an Knowledgebase article on it:

The workaround is to buy (if you don’t have one already) a cheap gigabit switch (sometimes found for as little as $10 USD) and put it between the My Cloud and the AT&T Uverse router. Or configure an unused router as a switch.

Just a few past discussions on the AT&T Uverse/My Cloud issue:

OK. I’ll try a switch between the uverse router and MyCloud - but this has been working for about 8 months with no problems. Why the change?

Just to close the loop on this - it appears it is an issue with the Uverse router. I reset it (unplugged and rebooted) and then the MyCloud worked. I will buy a switch to see if that prevents the problem from recurring.