MyCloud backs up only a portion of the photos from iPhone

Hi. I’m posting this after spending a week reading countless posts in this forum without finding exactly the issue I’m having: I configured the MyCloud App in my iPhone to backup photos and videos automatically. After working well for about a month, now it only uploads a portion of the pictures. For example, if I take 30 photos and get back home to wifi, the app will only upload 17 photos, for example. I didn’t do any change that could have generated the issue as it was working as expected before. And this behavior persists after I tried all I could find in this forum: delete and reinstall app, reconfigure backup destination folder, leave the app open and the phone unlocked for a long while, close the app and open it again, monitor the “activity” tab (which shows “complete”), remove and reconfigure device rights into MyCloud and so on. It’s like the app is not recognizing new pictures as new and just backs up a few of them. As having to check which photos were backed up and which weren’t defeats the purpose of an automatic backup, I’m turning to you, more experienced users, for other tips. In case you’ve seen this being discussed in another thread, please point me in the right direction. Thank you very much.


What’s the file format of the photos?

The photos are regular iPhone photo files: .jpg

I wonder if you ran across this post of mine in this SAME forum that describes the problem and the solution?

Thank you. Yes, I read this post and tried its procedures at least 5 times over a week before posting mine.
It’s not the same problem. I’d love to solve it so easily. You’re describing what to do before large back ups and my issue is that, regardless of the size of the back up, for some reason, the app/software is selecting certain photos to back up and leaving others behind. For some unknown reason, it seems the app/software is not recognizing all photos and videos as new and is copying only some.
Thank you for your help.

1 Like

What I do is upload the new photos/videos into an empty folder named New Uploads. After uploading them, I move the files there into their own folders (e.g. seperate photos and videos) This gives me a completely empty New Uploads folder again for next time. Could this info help you?

Thanks. I tried that as well. But only some of the photos are backed up in this empty folder. I moved them to another permanent folder and monitored it for a while. No new photos were backed up. I then closed the app and took 10 test photos with the iPhone and opened the app. In the “activity” tab, I monitored the back up until it showed “completed”. I then checked the folder and, out of 10 photos, only 6 were backed up.
For some reason unknown, the app is not recognizing all new pictures as new, just a portion of those.

Weird. I will have to think about this for a while, but I don’t think there is an easy solution, so after the weekend contact WD support via phone.

This is happening also in Android. I have a galaxy S7 and the same behavior from the app as you.

All that comes to mind is a router that is dropping data.

also having the issue of all the photos not uploading (latest android)

Are all your photos saved directly on the iPhone rather than iCloud’s standard photo back up? The way to check is to go to a photo on your iPhone that hasn’t upload and click ‘edit’ if the item then shows as downloading it means that only the preview/thumbnail is saved on your phone and that’s why the myCloud back up doesn’t pick it up.

I am having big problems with this at the moment as I don’t have enough space to save all my photos on my phone in order to create a complete back up…