Mycloud android app log on problem

I’ve been having trouble with the android app for a while now. Several different units have lost connectivity via the os3 app. It started with an MX111 box that won’t accept the log on credentials. I have tried resetting the password, but it is still not accepted. I have checked logging into and its accepted straight away. is this a problem with android versions no longer being supported, as my tablet running 8.0 Oreo is now having the same problems. I can get by with web access, but that means i am no longer able to stream files to watch and downloading beforehand is a pain. Any help would be appreciated.

1 Like

the search-function is working…

Make sure to start a support ticket with WD Support on your issue. The more people who raise the issue officially with WD hopefully the faster they’ll issue a fix or workaround. It appears others are having similar issues.

FYI in the future one can use the forum search feature, magnifying glass icon upper right, to find similar discussions to the issue one is having.

I already have a ticket open with them and have updated it to tell them the problem is with their SSL cert. I’ve worked my way up to “Level 3” support so hopefully I’ll hear back from someone today or tomorrow.

In the meantime, I’ve just started using FTP to connect to my device. That works fine and gives me nearly the same functionality as their craptacular app.

1 Like

IMHO FTP is not a good option. Streaming is intermittent, and it is not a very secure protocol.

same problem here, after the new update i cant connect with my android tablet to my WD devive,
it is visible under win 10 and i have acces to it but no longer via my android tablet.
Well it was working for almost 5 years and now nothing work :frowning: