MyCloud and Public Access

Rather than hijacking another users thread. I’ll post my own.

So I’m wanting to use my MyCloud as a storage device for a number of people (externally) So they are able to access my MyCloud from their home/s.

I want them to be able to have their own account and be able to add folders / files via Windows Explorer. I did this originally using Port Forwarding. I’ve now realised that by doing this, ANYONE can access the content on MyCloud (if they know my IP address and NOT just the people who have accounts.)

So please could someone explain to a Networking Dummy. How I can achieve this without allowing unauthorized people from accessing our content. The MyCloud was fantastic, until I found out the public could access our content.

Many thanks and I appreciate any help.


Have you setup Cloud Access with accounts? Proper users with logins and passwords. Share permissions for those users. Admin Only login and password for Dashboard configurations? I’m not sure about port forwading as some have “Bricked” their units.

Are you behind a Firewall?

How are people seeing your My Cloud network behind a Router? Are you running WiFi?

Please explain your setup configuration may help. Example:

  1. PC’s wired or WiFi?

  2. My Cloud connected to router or switch?

  3. As I mentioned … not sure about port forwarding.

  4. What firware are you on?

  5. Every user has their own login and password?

  6. Every user has “Shares” set for “Read, Write”

1. PC’s wired or WiFi? - MyCloud is through wired connection. I’m using both Wireless and Wired Connections to access the MyCloud (locally and through the web)

2. My Cloud connected to router or switch? - Router

3. As I mentioned … not sure about port forwarding. -  The port forwarding is working fine, I’m able to access MyCloud across the internet and locally, using Windows Explorer. The only issue is. if anyone knew my IP Address, they could access EVERYTHING on my MyCloud, even though Each user is setup with a user name and password, and each share is set to private. 

If I access the drive through Map Network Drive. Then it will ask me for a username and password for the folder I’m trying to access. HOWEVER if I create a shortcut on my desktop and Type in \myipaddress\
 and then connect through the internet to my ip address, using a mobile broadband dongle, on another PC. EVERYTHING on my MyCloud shows up and it does not request a username and password.

4. What firware are you on? The latest version.

5. Every user has their own login and password? Yes

6. Every user has “Shares” set for “Read, Write”  Yes

If I am understanding correctly your computer connects to the internet through the dongle that is on another computer … correct?

So bascially you are connecting through a Mobile Phone signal?

Is there anyway that the Dongle itself has a passthrough that allows this access to your home network?

One way to check what is open or closed (port wise) is to go to and use their “ShieldUp” to test your network. I have done so with mine and it will show you where you might me venerable. I’m not saying this is the issue, but certainly eliminating any potential can not hurt.

System 1 - My computers, router and MyCloud are all connected to the internet through my home broadband connection.

System 2 - I’m then using a seperate laptop connected to the internet through a Mobile Broadband dongle to test my MyCloud to see how it behaves when other people connect to it through the internet. (if that makes sense?) The seperate laptop is NOT connected to my home network.

However. When I go onto my seperate laptop (System 2) and enter a shortcut on my desktop //myipaddress/  (System 1 IP Address) I’m finding that ANYONE can access the contents of my MyCloud through Windows Explorer. Even though ONLY the user accounts who are registered should be able to access the contents.

The user accounts and shares are all configured correctly. Username and Passwords and Read/Write permissions are all correct.

What ports did you forward?

Ports 80 - 443 (as described in the manual)

However Protocols TCP & UDP ( I werent sure which one MyCloud required. So I enabled them both)

Is that 80 THRU 443, or do you mean 80 AND 443? If the former, that’s not safe, and is not what the manual suggests,

Ooops :dizzy_face:

It was open 80 through to 443. So I’ve fixed that now.

That has also fixed the problem of my mycloud being openly discovered. However now I’m unable to Map Network Drive using my external ip address.

So is there no way for my friends to connect to my MyCloud via VPN or Map Network Drive?

The apps/software provided is not really ideal. I would much prefer them to be able to access my MyCloud via Windows Explorer.

Thank you for your help with this by the way. It’s appreciated.

Have you read the User Manual, see Accessing Your Cloud Remotely, this may be what you are looking for.


Be sure to read,

Accessing Your Personal Cloud on the Web


Thanks, but no that is not what I’m after.

I want my friends to be able to access my MyCloud remotely without having to login through wd2go website. By either Adding a Map Network Drive (using my external IP Address) and then logging in with their mycloud account details (I’ve setup for them) or through a VPN.

The first time, your friends will have to go through to map the share to a drive on their machine. Then they will be able to access through that mapped share.

Alternatively, you could set up FTP access to your NAS. YOu will need to open/forward the FTP ports to your NAS