MyCloud 4TB won't go into Energy saving mode

You need to enable ssh in the dashboard. Then you can ssh into the My Cloud and enter the commands.

Thanks :slight_smile:
I use WinSCP, it allows me to login, view files and edit them but it wont allow me to execute a command.
Or does it?

Danny

Not sure . I use putty.

ok

I executed the following in the command terminal:

/etc/rc2.d/S20restsdk-serverd stop
mount -o remount,noatime,nodiratime /dev/root /

and nothing changed, green LED is still flashing and the drive still wont go into sleep.

I tried editing the files as you instructed but in the /etc/rc2.d/ directory the S98user-start file is marked in red and when I try to edit it, it says file not found. An ideas please?

It does allow you to execute commands. Click the icon highlighted in the graphic.

The green led on the back does not indicate that the disk is in standby. The front
led will go from solid blue to almost off when it is in standby mode. Also the disk
will wake up at midnight, 3:00AM 8:00AM 4:00 PM and 8:00PM
When the disk wakes up it will take 10 minutes of no disk activity before it will
enter standby mode.

Do a forum search for “sleep” if you haven’t done so already. LOTS of discussion on this particular issue of the single bay My Cloud not entering or staying in sleep mode.

For example on my first gen single bay My Cloud this is my /etc/rc2.d/S98user-start that I used for a period of time.

#!/bin/sh
# User startup script
# should run automatically after every reboot, and be unaltered by firmware upgrades
# so should sort out the mess caused by firmware upgrades

# stop and disable indexing services (just stopping the service not disable)
/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop
# update-rc.d wdmcserverd disable
# update-rc.d wdphotodbmergerd disable

# stop RESTSDK server daemon
#      for OS3 only
/etc/rc2.d/S20restsdk-serverd stop

# stop unwanted wakeups
mount -o remount,noatime,nodiratime /dev/root /

My single bay first gen sleeps erratically even with these changes. Some devices on the local network tend to keep the device from sleeping apparently. Still though, get MUCH better sleep time with the above script then without it. Without that script my single bay never sleeps more than 6 seconds or so before it wakes up (probably because of the stupid monitorio.sh script.

I’ve run into a new condition that keeps the disk from sleeping. If I open windows explorer
while I have mapped My Cloud drives. One of my My Clouds will not go into standby. A network
trace shows that the windows system is issuing a SMB2 QFID request every 30 seconds or so.
Don’t have a lot of information about this condition yet. This QFID request has something to do with
getting size of the share or something like that.
Funny thing is that not all My Clouds wake up during this condition. My Gen1 My Cloud seems to sleep thru this process. The gen2 My Clouds which have a newer version of samba seem to be affected by this condition.

Yes, having a mapped Share/My Cloud drive will cause wakeups. Had that problem on my first gen where every time I brought a PC out of sleep or booted the PC it would wake up the My Cloud, then keep it awake. Only fix was to not map Shares. :frowning:

Then there is the editing of the montinaro (spelling?) file. Frustrating we customers have to edit files and stop WD services just to get the hard drive to spin down and sleep when not in use.

Bennor,Rac8006

thank you so much. the drive simply wont go to sleep, I can always hear and feel the disks spinning and I’m sick of it. How long can it live like that? And I only get data from it an hour a day maybe…

I should have gone with an external usb drive and connected it to the usb input of my router and save all the hassle.

Yes it is Frustrating. I find it interesting that only the gen2 My Clouds stay awake when
a a drive is mapped. Not sure why windows needs to get the share size every 30 seconds.
Also sometimes even one of the gen2 My Clouds will sleep thru the 30 second request while
the other gen2 won’t sleep.
The way WD wrote the software is very amateurish. They scan the disk checking every file
looking for new files. When there is a function in Linux to tell an application when a new file is
created. Then they go to a busybox system which makes it difficult to do most Linux commands.
Most of the code on both My Clouds is several years old. Like samba is not supported in the real world.
They release the GPL source. But when you compile from the GPL source. You don’t get the
same application with the same compile time options. Most likely because they didn’t but from the same GPL.
I guess that is enough venting.

The gen1 is difficult to troubleshoot why the disk won’t sleep. In your case
I would turn off as many feature in the dashboard that you can get along without.
Keep SSH enabled. Start experimenting with which processes you can live with out.
The following script will try to tell you which files are being accessed. I usually run it with the following command.
bash CheckGen1.sh 60

This will check the /proc/diskstats file every 60 seconds. If a read or write has occured
it will scan the filesystem looking for the file that was changed in the previous 60 seconds.
This might help determine why your disk does not sleep.

CheckGen1.sh
#!/bin/bash
Device=(“sda4” “md1”)
sda=(" " " " " " " " " " " " " " " " );
function test () {
if [ “$1” != “$2” ]; then
da=date +%k-%M-%S
A=$1
B=1
ior_sda=${A#-}
iow_sda=${A%-
}
A=$2
ior_sdaold=${A#-}
iow_sdaold=${A%-
}
let a=ior_sda-ior_sdaold
let b=iow_sda-iow_sdaold
if [ $4 -ne 1 ]; then
echo -n $da " "
fi
printf “%4s %4s %4s " $3 $a $b
fi
}
A=cat /proc/cmdline | awk -F= 'BEGIN{RS=" "}{ if ($1=="root") print $2 }'
Device[1]=${A:5}
date
while :; do
i=0
for x in “${Device[@]}”
do
sda[$i]=awk -v disk="$x" '{if ($3==disk) printf "%s-%s",$10,$6}' /proc/diskstats
i=$i+1
done
let B=i=0
for x in “${Device[@]}”
do
test “${sda[$i]}” “${sdb[$i]}” $x $B
i=$i+1
done
sdb=(”${sda[@]}")
if [ $B -eq 1 ]; then
echo
find /bin /etc /boot /lib /usr /CacheVolume /DataVolume /nfs/SmartWare /nfs/TimeMachineBackup -cmin -1
fi
sleep 4
done

Hi rac8006

WDMyCloud:/DataVolume/shares/Public# bash CheckGen1.sh 60
CheckGen1.sh: line 3: '\r': command not found CheckGen1.sh: line 4: syntax error near unexpected token `‘{\r’’
'heckGen1.sh: line 4: `function test () {

I want to know the sleep issue but I find this error when I run the script. Would you advise?

Andy

Which device do you have Gen1 or Gen2?

Mine is Gen1 4.05.00-342. I spent more than 3 days on the sleep issue. Tried all methods after searching the nearly all posts. Still cannot solve the issue. Sleep around 10 minutes then wake up again. I think Samba is the main issue.

Would you advise whether I downgrade the firmware to which version or do other steps as well? My objective is to sleep around 80% of time.

Andy

Cannot speak for others but I was never able to get my first gen v4.x My Cloud to sleep properly. It was always waking up to perform various tasks even though the scanning was disabled via firmware tweaks. It ended up being a combination problem. Samba is a partial cause in addition to how the firmware is coded. Any time I brought a Windows PC out of sleep, or booted it, it would wake up the My Cloud. Best guess is Samba traffic is triggering the My Cloud to wake up.

Then there is the firmware itself. Short of neutering the entire firmware which disables most if not all features/options, it will periodically wake up to perform actions. One way to test is to put the My cloud on a network all by itself and check how often it sleeps. The second you enable options like remote access, iTunes/Twonky, and other features the My Cloud won’t stay asleep for long periods of time (at least in my experience).

I spend many wasted hours and made many past posts trying to fix the sleep issue. In the end I gave up. Did the basic firmware tweaks and just live with the fact it doesn’t sleep due to crappy firmware and the Samba issue. YMMV

Did you cut and paste from the script above? If you did it has incorrect characters when copied.
If you are familiar with vi or nano you should be able to edit out the bad characters.
In my looking into the sleep issue. I found several issues with samba and other OS functions that
would effect the sleep issue.

I already take into account rac8006 and many people’s advice in this forum and edit the S98user-start file as follows

#!/bin/sh

User startup script

should run automatically after every reboot, and be unaltered by firmware upgrades

so should sort out the mess caused by firmware upgrades

Move Msg.sock to temporary RAM location

/etc/init.d/samba stop
mount -t tmpfs -o mode=0700,noatime,size=2m tmpfs /etc/samba/msg.sock/
/etc/init.d/samba start

Stop and disable indexing services (just stopping the service not disable)

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

stop RESTSDK server daemon

for OS3 only

#/etc/rc2.d/S01motd
#/etc/rc2.d/S01wdAppEntry
/etc/rc2.d/S03atop stop
#/etc/rc2.d/S04apache2
#/etc/rc2.d/S16ntpdate
#/etc/rc2.d/S16openvpn
#/etc/rc2.d/S16ssh
#/etc/rc2.d/S17monitorTemperature
#/etc/rc2.d/S18monitorio
#/etc/rc2.d/S20minidlna
/etc/rc2.d/S20nfs-common stop
/etc/rc2.d/S20nfs-kernel-server stop
/etc/rc2.d/S20restsdk-serverd stop
#/etc/rc2.d/S20samba
#/etc/rc2.d/S20sysstat
#/etc/rc2.d/S20vsftpd
/etc/rc2.d/S20winbind stop
/etc/rc2.d/S50netatalk stop
/etc/rc2.d/S60mDNSResponder stop
/etc/rc2.d/S61upnp_nas stop
#/etc/rc2.d/S75sudo
#/etc/rc2.d/S84itunes
/etc/rc2.d/S85twonky stop
/etc/rc2.d/S85wdmcserverd stop
#/etc/rc2.d/S86commgrd
/etc/rc2.d/S86wdphotodbmergerd stop
#/etc/rc2.d/S89cron
#/etc/rc2.d/S90lltd
#/etc/rc2.d/S91nspt
/etc/rc2.d/S92wdnotifierd stop
/etc/rc2.d/S95wdAutoMount stop
#/etc/rc2.d/S96onbrdnetloccommd
#/etc/rc2.d/S98user-start
#/etc/rc2.d/S99wdAppFinalize

stop unwanted wakeups

mount -o remount,noatime,nodiratime /dev/root /

Stop Cron

/etc/init.d/cron stop

But the sleep effect does not improve much. Therefore, before I give up, I would like to know whether the firmware downgrade would actually help according to your past experience.

I wish I could help. I have not worked on the My Cloud devices for a couple of years.

Downgrading does open up previously patched security vulnerabilities. So you will need to decide if potentially solving or dealing with the sleep mode by rolling back the firmware is worth opening up previously patched security vulnerabilities. Also note that if you use Remote Access (Cloud Access) downgrading may break the ability to access your My Cloud remotely.

Do a search forum search for “sleep” (https://community.wd.com/search?q=sleep%20category%3A105), and look at the dates of the posts. Try to find the earliest posts to see what firmware version (if listed) people were using. This failure to sleep issue has been around for many years and many past firmware releases. If you do find a prior firmware version that may work one can try to roll back to is.