MyCloud 4TB won't go into Energy saving mode

Full factory reset will not fix the problem. The problem is in the firmware. There are at least two or more issues that cause the My Cloud to not sleep. Both of which can be corrected. With the
corrections my My Cloud sleeps 495 hours out of 558 total hours up time.

RAC

I really appreciate your help, and like I said, if the factory reset won’t fix it, I’d like to try what you said with stopping this restsdk-process. Would you give me a tip about the second issue you know? Or did I overread it?

If when you are SSH’d into the My Cloud do a mount command. It will list all of the partitions and how and where they are mounted. If you look at any of the sd4 partitions you will see that they have two options noatime and nodiratime. But the / partition does not have these two options.
This means that any time a file on the root partition is accessed the inode for that file will have its atime updated. When this happens a kjournal entry is written to the disk. These journal entries get written several times a minute.
On my system i do the following command:
mount -o remount,noatime,nodiratime /dev/root /

I’ve spent a lot of time looking into the sleep issue.

RAC

I really do appreciate your help sir, and I’m going to look-up all that stuff after work, as soon as I’m home.

So I’m first going on my Cloud using SSH and stop this restsdk process (/etc/init.d/restsdk-serverd stop). Then I watch out my mounts, and do your statement or going save and posting my output first.

Btw. the full factory reset took around 15-16 hours, and didn’t helped at all. The full default settings are still not working.

Edit: Couldn’t work on this yesterday. Today after WOrk I’ll do what I just said above. Thanks everyone.

So I stopped the restsdk-serverd process and I remounted the /dev/root /. It seems to work now. I tried alot of stuff using my TV/HD Receiver to play Videos etc. and decided to use my WD TV for this. So now everthing seems to work brilliant.

I setted up the NAS the way I want to, and I’ll check before going to bed if the NAS still goes into sleep. I did some tests already before I connected all other devices in my network, but I’ll check this just to make sure everything is fine now.

Anyway, I really really want to thank you rac8006.

One more question. In case I need to shutdown/reboot my cloud, I need to stop the process, OK. But do I have to remount every time too?

And is there some way or some startup script where I can change the code that this process won’t even get started?

Yes you have to remount also. You can put some code in the /etc/rc2.d/S98user-start file.
Put in this file those things that you enter from the keyboard on reboot.
as an example put these two lines in the file

/etc/rc2.d/S20restsdk-serverd stop
mount -o remount,noatime,nodiratime /dev/root /

RAC

1 Like

Tested it some days now works like a charm. I didn’t edited this startup script yet, but I’ll do this someday.

All that just to get it to SLEEP? I guess Ibhave no hope of fixing the endless list of problems with my new one. Why didnt they put a (usable) USB port on it. UNIVERSAL Signal Bay, except when its on a WD…

USB = Universal Serial Bus. As anyone who has worked in IT for 25 years would know. They’d also know that you wouldn’t have any luck accessing a PC’s HDD via any of its USB ports…

Signal / serial who the heck cares it doesnt WORK in Any Universal Way on THIS DEVICE. AND One can almost Always Access a hard drive via its USB sarcastic JERK like with a MyBook or any external USB Drive just not with THIS one…,

Except the My Cloud is not an external HDD. It is a NAS, which is a USB host, not a client.

It seems like the My Cloud does not meet your needs. I would recommend selling it and moving on.

1 Like

Even it its not regarding this topic and you should maybe open a new thread, whats the matter. Mine USB works like a charm.

I’ve had my 4TB srive for almost a year with media serving, iTunes and remote access on the entire time. It used to go into sleep mode just fine but it hasn’t for the last couple of weeks. The LED is steady blue and I can feel the drive spinning in the case though I don’t hear any actual drive activity unless I’m accessing the drive. I’ve tried resetting it multiple times but it still won’t go into sleep. Any thoughts?

Simply check the process and mountng options just like described above from rac.Maybe you just got a new firmware update.

Hello my friend. Having the same problem and only now saw this thread.

How do I enter these commands? Where?

I have no open interface to write commands in the dashboard and it’s the only interface I have with the device.

Thanks :slight_smile:

Danny

You need to enable ssh in the dashboard. Then you can ssh into the My Cloud and enter the commands.

Thanks :slight_smile:
I use WinSCP, it allows me to login, view files and edit them but it wont allow me to execute a command.
Or does it?

Danny

Not sure . I use putty.

ok

I executed the following in the command terminal:

/etc/rc2.d/S20restsdk-serverd stop
mount -o remount,noatime,nodiratime /dev/root /

and nothing changed, green LED is still flashing and the drive still wont go into sleep.

I tried editing the files as you instructed but in the /etc/rc2.d/ directory the S98user-start file is marked in red and when I try to edit it, it says file not found. An ideas please?

It does allow you to execute commands. Click the icon highlighted in the graphic.