MyCloud 4TB on Mac OSX 10.6.8 & on home Network - ISSUES

Hi everyone, this is my first post here. Hopefully i can find some assistance / help to make this run smoothly!

I had purchased a WD Mycloud 4TB and just set it up in my home on our network, and i’m having some varying issues, which I will try to list below.

On my mac pro 3,1 i downloaded and installed the WD My Cloud app, and it recognizes the drive, but it won’t connect, regardless of how i try. I’m attaching screen caps below to show you what i’m facing.

That being said, the drive shows up in my finder, and i can “sometimes” connect. When i was able to connect, i was able to put movies etc on it to which, was very handy to watch on our smart tv in the living room. Awesome.

However, there are a few things that i can’t get working.

I have the mycloud plugged in all the time. It seems that it goes to sleep. Sometimes i’m able to see it in my finder, and i’m able to connect. other times, it won’t let me connect. Other times, it won’t show up on the finder at all. Is there a way i can “wake up” the drive from my computer, or in some other way, other than me having to go to unplug it and plug it back in?

I’ve had to resort to unplugging the power cord from the mycloud and let it sit for a minute, and then plug it back in. This process only works a few times.

It will show up in my finder, and after it says “connection failed”, and i click ok, the mycloud disappears from the finder.

It will “sometimes” reappear, and when i try to connect again, it gives me the same issue.

FYI - this is the ONLY way though, that i’ve ever been able to connect (when it lets me) to my mycloud drive. The app recognizes it, as well as the IP address of it, but has never let me connect.

As for the WD My Cloud app, it will recognize the drive, as well as the IP address, but when i try to connect to it, it won’t. keeps saying there is an error. (see several attached screen caps below). After trying this, when i try to connect again (using the app), it doesn’t recognize the drive at all.

If i click on any of the links on the bottom right in the app (screen shot below):

“Search for devices in my Network”
“Show previously connected devices”
“connect to devices with activation code”
“Connect to devices with WDMyCloud.com login”

None of them will recognize my Mycloud, even if it was previously recognized on the first attempt to connect.

Something real screwy is happening here, and i’m not sure why.

I also have a macbook Pro that is able to connect to my network via wifi, and i’m able to see the WD Mycloud in the finder and desktop no problem.

My Macpro 3,1 is connected via ethernet cable, and is having issues, and i’m not sure why.

Any help would be VERY much appreciated.

Thanks in advance!

(Hopefully the 8 screenshot attachments uploaded ok) - EDIT - new users can only upload 2 images. I’ll have to find a way to upload the remaining 6 images.

Screen shot 2020-03-30 at 4.21.14 PM

Screen shot 2020-03-30 at 4.21.50 PM Screen shot 2020-03-30 at 4.22.07 PM

What specific “My Cloud app” are you trying to use? The WD Sync app? The My Cloud Desktop app? If trying to use the My Cloud Desktop program, that software has been end of life since 2016 and is no longer supported by WD. Recent firmware updates to the My Cloud breaks that program.

My Cloud Desktop App No Longer Works with a My Cloud or Login Not Authorized
https://support-en.wd.com/app/answers/detail/a_id/25159

If one is having trouble accessing the My Cloud by it’s name in Finder, try accessing the My Cloud by it’s IP address instead as a troubleshooting step. It is also a good idea to reserve an IP address for the My Cloud within the local network router’s administration interface so the My Cloud always uses the same IP address.

When in doubt try to access the My Cloud Dashboard as a troubleshooting step. All configuration of the My Cloud is done through the My Cloud Dashboard.

How to access the Dashboard on a My Cloud (single bay) device
https://support-en.wd.com/app/answers/detail/a_id/15104

Hi Bennor, thank you for the reply.

I did not do any updates (that i knowingly am aware of), and the version of “WD My Cloud.app” is Version 0.0.0

FYI - i never installed any application onto the Mycloud drive itself. I only installed the Mac OSX desktop app “WD My Cloud.app”. This app has never been successful. It only recognized the WD Mycloud as well as the IP address, which i entered into my network, to ensure that it would allow access to it. However, the app has never worked, and only given me error messages. To be honest i don’t really need the app, and will uninstall it. If i am able to have Finder / Desktop access that will be more than fine.

The ongoing problem, is that this access, is extremely limited, and only works on a ‘whim’.

Lastly, i did have access and do have access periodically, but rarely, via the finder.

So it works, but then mostly doesn’t.

So, it if never worked at all, and i could not have had any access at all…that would be one thing. But I have had access to it, so i know that the connect abilityto it does work. (I have put almost 30 movies on the drive so far from my Mac Pro 3,1).

So, this is an odd one, and i’m really eager to solve this with the generosity of anyone’s help!Screen shot 2020-03-30 at 8.52.05 PM

Currently these are the only official WD apps for Mac with respect to the single bay/single drive My Cloud devices (https://support-en.wd.com/app/products/product-detail/p/126#WD_downloads):

WD Sync for Mac
GoodSync for WD
WD My Cloud Setup for Mac (https://www.mycloud.com/setup)

The app you are trying to use, WD My Cloud Desktop is no longer supported. If your My Cloud is configured to update it’s firmware automatically, then a recent firmware update (within the last year) broke the ability to use the WD My Cloud Desktop program.

For local access one is supposed to use Mac Finder (or Windows File Explorer). For remote access one is supposed to use MyCloud.com or the My Cloud app for iOS or Android.

If one is having trouble with being able to access their local My Cloud using Mac Finder or Windows File Explorer there are a few things to check as troubleshooting steps.

  • Make sure to assign the My Cloud an IP address within the local network router (or configure the My Cloud for a static IP).
  • Check to ensure all network devices are on the same IP subnet. Make sure the router isn’t assigning different IP address subnets to different devices. Like WiFi using 192.168.2.x and wired devices using 192.168.1.x subnets.
  • Temporarily disable any security/anti virus software on the local computer that is exhibiting access issues. Certain software may affect local network access.
  • Disable Sleep Mode on the My Cloud Dashboard > Settings.
  • If the computer is using WiFi, check the local network router to see if WiFi or client isolation is enabled. If it is, disable it and test access.
  • If the computer is using WiFi make sure it’s not connecting to a “guest” network which may have additional limitations in place.
  • Turn off all other network devices and see if the issue persists. If it doesn’t then turn on each network device one at a time testing access till the issue returns.
  • Check (if possible) to ensure SMB1.0/CIFS is enabled by the computer’s operating system.
  • In certain rare cases there can be a conflict between the My Cloud and an ISP/broadband provided router. The workaround is to use a network switch between the My Cloud and the router (https://support-en.wd.com/app/answers/detail/a_id/3637).

The Windows version of the My Cloud Desktop program also no longer connects because my first gen single bay My Cloud is running the latest firmware.

If that is the case, how would i know what firmware my Mycloud currently has?

Also, how would one disable the “auto update”?

Lastly, if that is the case - the firmware was updated without me knowing - how can i revert it? Will deleting the drive, and doing a reset, change it back to original factory settings / firmware?

Thank you.

One would access the My Cloud Dashboard to see information about the device and to configure it. If you haven’t done so already You may want to read through the My Cloud User Manual (https://support-en.wd.com/app/products/product-detail/p/126) which has specific chapters explaining the various features and options found in the My Cloud Dashboard.

How to access the Dashboard on a My Cloud (single bay) device
https://support-en.wd.com/app/answers/detail/a_id/15104

  1. Using a computer that is connected to the same network as the My Cloud device, launch a web browser
  2. Enter either the name (or IP Address ) of the My Cloud device into the URL field of the web browser. For example:

Dashboard example:

(Note this is a second gen v2.x firmware Dashboard example, the first gen v4.x firmware Dashboard looks slightly different)

One can attempt to roll back the firmware but doing so will open up potential security issues that later (or the latest) firmware has closed. Even then, rolling back may not guarantee the My Cloud Desktop program would continue to operate as before.

Performing a 4 second or 40 second reset via the reset button on the back of the My Cloud will only reset the My Cloud settings.

Performing one of the three Factory Reset options found in the My Cloud Dashboard > Settings > Utilities > System Factory Restore section does not change the current firmware to an earlier version. Depending on which Factory Restore option one chooses one may only reset the Dashboard options to factory default, or one could erase (or securely erase) all data on the drive and reset the Dashboard options back to default.

One could try one of the various unbrick methods to roll the firmware back to much earlier versions but doing so typically requires more knowledge in using Linux and or issuing various commands via Telnet or SSH. Generally a typical unbricking of a drive will erase all data on the drive.

Thank you again Bennor for all this info. Really appreciate it!

How can you tell which Gen my MyCloud 4TB is? Will the model number tell?

If so, the model # is: WDBCTL0040HWT - NESN

If you don’t want to access the My Cloud Dashboard to see the firmware number then look at the P/N number on the bottom of the single bay/single drive My Cloud enclosure. If that P/N number ends in “-00” then it’s a first generation My Cloud and uses 3.x/4.x firmware. If that P/N ends with “-10” then it’s a second generation My Cloud and uses v2.x firmware.

It’s not that i don’t want to access the My Cloud Dashboard, i’m unable to.

I logged in, and can’t find it.

The last bit of my P/N number is: …40HWT-10

So, by your description, mine is a 2nd generation?

Thank you.

What are you logging in to using the web browser? MyCloud.com? Or, as the previously posed WD Knowledgebase articles indicate, the My Cloud Dashboard http://wdmycloud.local/?

One can also access the Dashboard by using the My Cloud’s IP address, which can be found in the router’s DHCP client section/list.

MyCloud.com is the remote access web portal. It is not the My Cloud Dashboard.

So my firmware is: 2.31.204

Is there older firmware that i can download and manually install, to go backwards, so i could have control with the WD my cloud app?

Also, why would WD stop support for the apps that enable you to control / access your WD cloud? That is a stupid foolish move, and makes being a WD customer even more frustrating.

See my post earlier in the discussion for links to older firmware and how to possibly roll the firmware back and why doing so may not be wise.

Companies routinely stop or end software applications for a number of reasons. Security or moving employee assets to other projects/software. This is mostly a user to user support forum. Most likely WD will not bother to tell us end users the exact (internal business) reason why they stopped supporting the software four years ago.

Hi Bennor,

I was successful in updating my firmware (in a backwards fashion) from the most current 2.31.204 to the first one (oldest available) 2.10.302

I was able to use the WD Mycloud app to access the files already on my WD My Cloud. I was NOT able to add any files with that app. Would always give me an error message when either uploading a video clip or music file. Screen cap of error attached below.

The other thing, was i was not able to connect to the WD My Cloud via the finder. It showed up, but always gave me a “Cant’ connect” error message.

So some steps forward, and some steps back.

Would simply updating each of the firmwares in order from oldest to newest and see if / when everything works as it should, be the best next course of action?

Thanks so much.

Best guess is that it couldn’t hurt to continue rolling back the firmware one at a time to see if the app starts working again.

But as one rolls back the firmware they are opening up security vulnerabilities previously closed with newer firmware. One has to make the determination if rolling back the firmware and opening security holes is worth the potential for hackers to compromise the My Cloud just so one can continue using a long discontinued program.

I have a similar issue on W10.

Suddenly MyCloud is gone. Web access does not work, IP address does not work and nor does wdmycloud. I powered down the router and MyCloud and managed (on one PC) to get the dashboard up to cofirm the latest firmware but then it vanished).

I can ping it, my router can see it but WD web services don’t work at all. HELP!