Mycloud 4Tb connection issues

Hi, I am having issues with my mycloud device the connection is extremely slow and often drops completely, (my LAN is healthy on all other devices) When i try a reboot the device starts up and flashes a orange / red power LED which after a short period turns to solid orange / red. Then after a while the LED goes a very dim blue which is hardly visual. At this point the device is accessible over mycloud.local but again connection is very slow. My time machine back ups are not working due to the slow / lost connection. Has anyone else experienced issues with the dull blue LED and if so what (if any) is the fix. I have tried creating a safe point to allow me to format the drive with no luck yet so hoping someone out there has experience of this?

I am using iMac to access the device (although it makes no difference which device I use to access)

sorry, one other point to note, as I have been reading some other posts on here, is the device appears to be permentantly media scanning? not sue if this makes a difference

More information is needed. Is the My Cloud connected to a Gigabit router/switch? How is your computer connected to the local network? By wireless/WiFI? Have you tried performing a 40 second system reset via the reset button on the back of the My Cloud? Have you tried putting a switch between the My Cloud and the broadband provider’s router?

Safepoint shouldn’t be “formatting” the USB drive instead it just copies the contents of the My Cloud TO the USB drive.

If you have a large amount of media files the My Cloud may take some try to scan those files. There are various methods to deal with the “scanning” the My Cloud performs on files but disabling the various scanning services may cause certain issues with the My Cloud media server or with certain remote access features.

Certain ISP routers (AT&T primarily) have trouble with the My Cloud and can cause some strange problems trying to access the My Cloud. The solution is to put a switch between the My Cloud and ISP supplied router.

Hi Bennor,
Thanks for the response, ill try to answer your questions as best as possible.

  1. mycloud is connected to a TP Link gigabit switch, then broadband router
  2. My computer is connected via power link adapter, into switch then router (Sky fibre is the provider)
  3. what i mean by creating a safe point is, creating a up to date backup before then formatting the disk, then recovering the data from the save point once formatted.

hi, i have tried the 4 second reset button but did nothing

Try the 40 second reset as indicated above. The 4 second reset only resets the Admin Password and Network Mode. The 40 second reset will reset the following:

Admin User Name (default = “admin”)
Admin Password (No password by default)
Device Name (default = “WDMyCloud”)
Remove all Users except Admin
All Share permissions (default = Public)
Automatic Firmware Update (default = off)
Network Mode (default = DHCP)
Remove all Alerts account association (default = not configured)
Mobile app account association (default = not configured)
WD Sync association (default = not configured)
Backup jobs (default = not configured)
Safepoint jobs (default = not configured)

To execute the 40 Second Reset:

  1. Power down the device and remove the power cord from the device
  2. Using a paperclip or narrow tipped pen, press and hold the reset button
  3. While continuing to hold the reset button, reconnect the power cord to the device and continue to hold the reset button for at least 40 seconds
  4. After releasing the reset button the device will reboot

Note: This process may take upwards of 15 minutes. Please wait until the Power LED is solid blue, indicating the device is ready to use.