MyCloid v2 - hard drive died - swap out for SSD?


#1

My MyCloud v2 originally had a 4TB drive which I pulled and put in my HTPC (I have another 4TB portable drive I use to back this up entirely).

I stuck my old 2TB in the mycloud and with a bit of work, got it working fine the last few months as a Time Machine backup host for my Mac. Occasionally it couldn’t be found first time but I put that down to it being in some kind of sleep mode.

Fast forward to last week- I got a new IP cam. Set up a share on the mycloud for it to send the backups to once a day. Three days in, it can’t be found.

Checked the unit and it wasn’t responding via SMB, Time Machine or anything else. It was also refusing Telnet connections.

Tried a four second reset then a 40 second reset. Blinking blue light for hours and still not connectable. Then powered off and on at the mains last night, and it was still showing a blinking blue led this morning.

Long story short, ripped it apart again and the hard drive was now whirring and clicking and sounding like death. When the drive was directly connected to a PC, the various EXT volumes eventually showed up, but couldn’t be accessed. It also caused the PC to hang when I tried to boot a Gparted live CD.

Tl;dr - I’ve bought a 240GB SSD and intend to use the Mycloud as a Time Machine backup point. Is there anything I need to be aware of? I guess it may have just been coincidence that the hard drive died shortly after setting up a daily transfer, but I am guessing an SSD might be more resilient to a hard power off (if ever necessary again?)


#2

Well it worked, eventually.

Two main issues

  1. trying to get a 3.5 to 2.5 adaptor in there that fits the board and the drive is nigh on impossible

  2. with the latest firmware the hard drive format never seems to complete. I ran through the process twice with no luck. Just did it again with the previous firmware and all seems to be fine. I initially got a message about RAID roaming but I formatted the hard drive via the gui and I’ve also just set it doing a full factory reset.

May attempt to upgrade the firmware but not sure.