MyClod and MyCloudHome issue

I have both WD MyCloud and WD MyCloudHome on my home network. This is on a MacBook Pro computer.

Using the computer FINDER I get a screen as shown below. The MyCloud device has my name and a blocked password with asterisks. However, I’m really not certain what the password actually is.

Using the FINDER on the MyCloudHome device shows the same name, BUT my password area is blank – no asterisk or anything.

Can I change BOTH of these to a new and same password?

MyCloudHome
Thanks.

These are different devices, operating with different operating systems. They don’t talk to each other.

Now. . . as for mycloud.com - - -> that might be more of an issue. I have multiple “mycloud” devices; and everything plays nice. The mycloud HOME line. . . may not be as flexible. I am nots as familiar with that product.

Please note that the My Cloud Home is not the same as the My Cloud. As I understand it (and I could be wrong as I’ve never used the crippled My Cloud Home devices) the main Share on the My Cloud Home is a public share so it does not need a password when accessing or mapping it.

On the My Cloud one can use the My Cloud Dashboard to access the Users to see what their passwords are and to create or change a password that one uses to access a Private Share on the My Cloud.

How to access the Dashboard on a My Cloud (single bay) device
https://support-en.wd.com/app/answers/detail/a_id/15104

There is a separate subforum for the My Cloud Home device: https://community.wd.com/c/home-cloud-storage/my-cloud-home