MybookWorld Edition undetectable - White lights blinking


#1

Faced with following problem. Once, after several months of not using the device, I wanted to get some photos, stored there. Did everything as usual, plugged the power, connected to router by patch cord and pressed the power button and … It didn’t launch. I just can see the flashing of status Led (bottom LED is lighting permanently, but top one is flashing continuously with long period 20 seconds)

can’t have an access to the device at all, neither through web console nor for data

what might all this mean and what is my chance to get stored data back?

My Book World Edition II


#2

Hi Grey,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.


#3

Looking for places to share this rather important information which I have not seen elsewhere on the web. My My Book World device failed with the same failure pattern (which indicates “Unable to boot” fwiw).

After messing around trying to mount the drive on a Windows machine in order recover the data (horrendous because the data partition is encrypted and can only be decrypted using a LINUX machine), I noticed that there’s a battery on the controller board that’s presumably used to power storage for the date and time. I replaced the battery (very common battery available at The Dollar Store, and drug stores), and the device subsequently booted up! Instructions for disassembling the device can be found on youtube.