MyBookLiveDuo Disappeared from Linux Network Boxes(Mint17)

I have a great functioning MyBookLiveDuo 4Tb with a 2Tb USB extension…in my windows network. It never fails and only emails me after a power outage.It is firmware current and I use Smartware current as well.

My issue is with my 2 linux machines. I had perfect access from both from the time i put linux on those devices until a week ago. No real idea why the access disappeared.  no more icon, none of the multitude of command line suggestions to mount. make directory , just find the thing .  nothing works and i tried as many as linux community and wd community forums had/have
the my book is not bricked, just doesnt appear in linux any more.

I have put in mac address searches, ip address and all, nothing shows up. no rejection or error message other than there is no such directory, device , address.

I am using Linux Mint17 Mate. I dont understand how it was perfectly accessible one day and no way to connect to it, even using bookmarks and ‘recent’ places . i know the ip address, whic can change  but no trouble with internet or any thing else. mac address stays the same and i cant manage to get the my book to show up at all anymore.

If someone has any idea , i would appreciate a direction to follow.

i cant begin to try to mount the thing until i can make it recognizable somehow, in linux. it just vanished one day and not just from one machine but the same in both, which otherwise are fine. i tried to fiddle with wired connections and wireless by making just an internal local network but still the my book doesnt show up

I have all my machines on a wired network, though i did try to make my linux laptop attempt to connect wifi. no luck in ‘g’ ‘b’ or ‘n’  i have a router and unmanaged switch(8) which works , just no more linux.

I got a few suggestions on how to mount but nothing works with finding the device in the first place.

if it could find and connect continuously automatically for a month, i cant figure out why it will not longer even find it.



Hi johnniedoo, Linux is not a supported OS, but maybe the some of the other users can share some advice with you. 

1 Like

Thanks for the reply, though i do realize that linux is not supported.

I was hoping for just the kind of response you implied might help

My interest is because for my first couple of weeks with linux on the 2 computers i am experimenting with in dual boot set ups did get, identify and show on each boot into linux the MyBookLiveDuo , no trouble. I could access my shares with the material i had in the my book. I was amazed and happy.

It just stopped loading it up when i boot for a week now. no idea why it stopped. I know only about 30days worth of linux.  am a total beginner with it. no idea why it showed up after i put linux in these 2 machines, didnt expect it. but was very impressed that linux was able to find and continue to load or whatever without any manual manipulation from me at all. It just did it and kept doing it till it stopped.  not sure why it stopped either.

Just a mystery to me. I have tried every single nearly realted hit i found  in linux questions forums as well as in google type search engines. i tried cut and past command line things from linux people for similar issues but not exactly the same, as yet.  havent yet found anyone in all the dozen or so places and forums i tried.  most have just encountered problems mounting, not my total inablity to find it anymore. it just showed up in my network connections for the first 2 weeks in one and for 10 of the 15 days in the 2nd computer. both stopped at the same time which seems to indicate that the my book did something or from that side something must have happened, neither of the 2 devices have the same structure  exactly so no reason for each to disappear at the same time. this is why i posted, finally, here on WD

mabye i need to rebuild something or other? who knows.  i don t want to mess with my book much at all since it functions perfectly and smoothly in my home group , network wireless, and wired and via an unmanaged switch in windows boxes.  not going to jeopardize a well oiled network for the sake of my 2 experimental linux machines. maybe later, not now, unless i know exactly what i am doing and what for.  no firmware or smartware updates happened in these days either.

I am just hoping for the best…

thanks again for the information. it is well appreciated.

I have been able to recover MyBookLiveDuo in the LINUX network.  I replaced my Linksys E3000 Dual Band Gigabit router. It hadnt been having any issues and was constantly fast and clean on the wired lan ports. There wre no complaints ever with the wireless side in 2.4 and 5Gz modes. always strong signals and little noise connected well no problems. a lousy usb pseudo NAS port which i never bothered with after trying it new.  I was very happy with it . But, I replaced it with a lower tier Buffalo single band N300 High Power router with the ‘Professional’ web interface DD WRT. It connects only at 2.4band but is clean and fast also a lousy usb /Nas attempt. tried it once , never bothered again. thus the My Book. 

I installed the Buffalo software and set up wireless drivers for linux adapters and worked with the gigabit LAN . Now , or for now maybe, I am able to see not only the MyBookLive Duo but also the 3 shares i set up in the my book and the 2TB Seagate BAckUP PLus usb3 device in the MyBook usb 2port. no passwords were needed either.  I had set that up long ago,last month that is, when i first installed Linux Mint17 and the my book was immediately recognized and i went through the initial password etc for access.

No idea how this new router connected with the old security things i had used. I am not familiar with linux well enough to figure out or pull up that information. It must be in there some where

just dont know the commands to list that data.  I had gone though all sorts of copy/paste suggestions for mounting the my book using samba and many other suggestions on the Linksys router though.

Not that this particular issue generated much interest, but the router change and changing a couple of the cat5e ethernet cables and today it is working. I changed the router 2days ago and at first, there was no sign of the Mybook in the network at that time. since, though , i have tweaked the router a tiny bit and maybe all that conspired to get it up, for now anyway.

makes a huge diffence in my ability to utilize the linux lap top in my home network to get at the 6TB of movies, backup or few other things stored on the MBL duo.

just thought i would share this successful, in some degree anyway, with the board