Mybooklive twonky and sharp TV issues

i’m having issues with my mybooklive and my dlna certified Sharp acquos TV.

I have managed to get nearly everything working, but when i use my TV to browse the video files on my mybooklive, most of all the folders are empty. 

if i select to show all video files, then i only get a very specific list. 

there does seem to be something in common with all these video files.

they are not high res. they are usually 4:3, if not always, so maybe it’s a filesize issue?

idk, it’s quite odd. hopefully someone could help.

It could be a file compatibility issues, did you tried checking the manual to see if the files you are trying to play are compatible?

The key with any dlna client and any dlna server

is to first know what your device does and does not support via dlna

and what you dlna server does and does not support

sometimes this is noted in the manual sometimes it is not

sometimes it can be vague sometimes it can be detailed

the starting point is the manual, what is the model # of your set?

what formats are the media in?

and knowing what video/audio codec used in the formats can be helpful

as a client may support a format, mp4 for example,

but it may not support all possible video/audio codecs that the mp4 format is capable of

I noticed that in 5.1.9 there is no client profile for the sharp tv

there is one in 6.0.39 and in 7.0.9 of twonky

but in all cases, the settings for the client profile are very very generic

I assume that in 5.1.9 the client profile being assigned to the sharp is most likely the generic media reveiver one

with that said, that brings us back to the what the sharp states it does and does not support for media formats

it will play the files from usb. 

i can see some of the files. it is only showing files in 4:3, so i’m wondering if maybe filesize has something to do with it?

i tried going ethernet connection to see if maybe that had something to do with it. maybe i need a gigabit router? would surprise me.

i tried twonky server from my laptop, directing to the files on my mybooklive, but i got the same issue, so it would seem that the twonky server version number is not the issue. 

couldn’t find anything helpful in tv manual.

For the most part aspect ratio is not a factor that I have ever seen in regards to local or dlna playback

Also, just because something plays via usb on the tv

it does not mean it supports via dlna, that is not a given or something you can take for granted

what they support via usb and dlna can and usually are two different things

I think we need more information, like the file type and some info about the files in question

Using Mediainfo ( a free tool ) why not post some the info about one of the files that will not play

For Example:

Complete name : D:\example.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom
File size : 488 MiB
Duration : 2mn 1s
Overall bit rate : 33.7 Mbps
Writing application : Lavf52.94.0

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 2 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 2mn 1s
Bit rate : 33.3 Mbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.670
Stream size : 482 MiB (99%)

ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Format settings, Endianness : Big
Codec ID : ac-3
Duration : 2mn 1s
Bit rate mode : Constant
Bit rate : 448 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Delay relative to video : 42ms
Stream size : 6.48 MiB (1%)

You could  also use MediaInfo and compare one that is working against one that is not working

and see if there is anything that sticks out that might be the cause

The reason for medinfo, is an extention is just an indicator of a container format

and containers can contain many different types of video and audio codecs

some will be supported some will not

I know you stated you looked at the manual, and thats a shame that things are not listed

I would contact the tv support group, and see if they could provide some clear answers

otherwise, were just throwing darts with a blindfold on

ya ok, good idea. i’ll do that.

ya. i don’t think 4:3 would of itself be a factor, but maybe it is a hint of what is teh factor. some of the files are avi that play and soe that don’t showup are also. 

i mean, i only noticed that the ones that play are 4:3 and lower quality. that’s why i suspected maybe filesize, or idk.

but i’ll do this, and maybe it will become obvious.