MyBookLive - high 'cpu wait' time, very slow!

Hi there. I’ve had a MyBookLive 2TB NAS for 2 or 3 years now. Just recently, I’ve noticed that the NAS crawls to a virtual halt. Trying to access the HTTP server can take 5 minutes, or just time out completely. Logging in via SSH is very slow, but is a bit more responsive.

During this time, trying to view or copy files from Windows is impossible, or only happens at about a 400KB/sec rate.

I’ve tried different cables and changing the routing (wireless to wired) - used different computers, but nothing changes.

After doing some research (warning: I know next to nothing about Linux!) I believe the problem is something internal to the NAS. These are the commands I’ve tried and their results:

MyBookLive:~# uptime
12:55:49 up 9:03, 1 user, load average: 5.26, 5.13, 5.15

MyBookLive:~# top -b -n 1 | awk ‘{if (NR <=7) print; else if ($8 == “D”) {print; count++} } END {print "Total status D: "count}’
top - 12:57:51 up 9:05, 1 user, load average: 6.18, 5.42, 5.24
Tasks: 87 total, 1 running, 86 sleeping, 0 stopped, 0 zombie
Cpu(s): 1.0%us, 2.2%sy, 0.3%ni, 11.3%id, 84.6%wa, 0.1%hi, 0.5%si, 0.0%st
Mem: 253632k total, 248832k used, 4800k free, 1920k buffers
Swap: 500608k total, 361984k used, 138624k free, 11456k cached

308 root -2 0 0 0 0 D 0.0 0.0 0:00.00 btn_t
316 root -2 0 0 0 0 D 0.0 0.0 0:00.05 a3gblink_t
4138 root 20 0 3840 384 320 D 0.0 0.2 0:00.64 lld2d
5935 root 5 -15 388m 120m 1280 D 0.0 48.5 9:40.16 smbd
10106 root 5 -15 129m 26m 1280 D 0.0 10.5 1:00.89 smbd
Total status D: 5

MyBookLive:~# ps -eo state,pid,cmd
D 153 [kswapd0]
D 308 [btn_t]
D 316 [a3gblink_t]
D 3713 /usr/sbin/nmbd -D
D 4138 /usr/local/bin/lld2d eth0
D 5935 /usr/sbin/smbd -D
D 10106 /usr/sbin/smbd -D

Can anyone help? Thanks very much in advance.

Some new info:

The high wait time seems to happen randomly, between 10 minutes and 10 hours after rebooting (which is the only way I had known to resolve the problem).

After it happened today, I tried to kill one of the two smbd processes. Kill -15 [PID] didn’t seem to work. Nothing happened even after 5 minutes of waiting.

I then tried kill -9 [PID] and the process instantly terminated, and my MBL seemed to be fully functional again.

Is it normal to have two smbd processes running? How do I stop this happening in the future?


Thanks for sharing your solution with the community.[quote=“seputus, post:2, topic:157450”]
Is it normal to have two smbd processes running?

As a recommendation, please contact WD Support for direct assistance on this case.