MyBookLive: Hide shares when user not authorised

Please update firmware so that a user can only see the shares he is allowed to access.

5 Likes

That’s not how SAMBA works.   

The list of Shares (the “Smb Tree”) is supposed to be available WITHOUT ANY user authorization.

The client asks the server for ALL shares, and the server responds with ALL shares.

That’s too bad. I would like that feature, too (in Sharespace). The old Novell NetWare was capable of that - and it was great because a user doesn’t get confused by directory entries he can’t access anyway.

I guess we need to take that request to the samba team because I don’t think it is feasible (or even wise) for WD to tweak samba.

It is possible with samba. The thing is, Windows can then get confused because it _expects_ to see all shares and does not (always) update the share list when the authentication changes. So: Linux and Samba can do it (client and server) but don’t expect Windows clients to behave properly.

Since the WD NAS run Linux, you can enable this by enabling SSH support and adding “hide unreadable = yes” in the /etc/samba/smb.conf file under the [global] section. (If you need more detailed instructions than this, just tell me.)

HIDE UNREADABLE = YES

hides FILES, not SHARES.

Will look at this as a user configurable option for future programs/releases. Thanks for the suggestion.