MyBookLive has just simply vanished

A couple days ago, the MBL drive just simply vansihed from my network…  I had set it to a static IP…

I have tried to reset the deveice using the “reset” button on the back - held it down for 4sec, plus even longer - just to be sure…  re-booted the device so many times it probably has my feet mark in it!!!

I even tried on a different with a whole new IPRange (was initally on 192.168xxx…  new router is a

I can find no ovidence of it anywhere on the old or the new network - through either IPAddress or MAC address…

Any other ideas / suggestions /  i just want to be able to retreive the data thats on the drive!!! My new network is Apple AIrPort Express

Mine did too!

Help please!

If you were set to static on the 192.168.x.x range and you replace the router which has another range, it will fail.

Now, if you are 100% sure the settings have been reset to DHCP, see if you see it listed on the leases for DHCP in the router. 

Not sure how it works on that device, but this might help.