MyBookLive gets very slow for writing

I have MyBookLive WDC WD30EFRX-68AX9N0. When I filled the storage to 2.9 TB (total is 3 TB), it started “breaking” when I copy a lot of small files to it. By “breaking”, I mean it becomes very slow. Reading from it is still possible, though slow, while writing becomes unusably slow. If I power-cycle the device, it gets fixed. Then if I e.g. run robocopy to copy lots of small files, it breaks again.

I tried the following:

  • freed ~200 GB
  • then reset device to factory defaults using quick format
  • then reset device to factory defaults using full format

Nothing helped. After factory reset, the device works fine. I run robocopy to copy ~800,000 files to it (total size way below 3 TB), and after ~200,000 files the device “breaks” as described above. In “broken” state, the drive’s LED never goes blue (sleep mode), it always stays blinking green, which according to the manual means “performing read or write operation”. Rebooting the device fixes it, but then after copying a few hundred files it breaks again.

Any help will be appreciated.

Probably writing thousands on small files you cause a very high load in indexing tables because they grow a lot ( with millions of entries )

You don’t say how is composed the 2.9 GB space but if it’s filled with millions of small files ( few kb ) it’s easy that the filesystem close to its limits.

Thanks Ricky65,

The drive was working fine with more that 200K files, maybe around 800K. Then after it started breaking like this, because reading from it was still ok, I saved all the data to another drive. Then I factory-reset the drive from web UI (that was working too), and then started copying back to it all the files that were already on it previously. And after ~200K it breaks. If it could handle 800K before, why would it break at 200K now?

So as you can see, it’s not millions of tiny files. It’s hundreds of thousands of “normal” files - office documents, source code (c#, javascript), etc. I also store movies on this drive, those files are 2-4 GB each as you can imagine. When I copy those, the issue does not happen. That’s why I said “when copying small files”. Though I obviously do not have 200K movies…

Any thoughts?