MyBookLive Duo constantly needing reboot

I have a MyBookLive Duo and also a MyBookLive.

Both have the latest firmware.  No issues with the MyBookLive.  The Duo looses connectivity with Windows machines and must be rebooted nearly every day.  Any ideas how to fix such a problem?

This could be an issue with the IP lease or some connection problems.

Try mapping the drive or assign an static IP and see if you will still experience the same problem.

How to configure a My Book Live or My Book Live Duo NAS drive with a Static IP

Are you still having the problem?

I have to reboot mine every day now too, and it has been configured with a static IP from day one.

I ran a wireshark trace when it works, and compared it to when it stops working… it appears that when it stops working, it fails to give a response to a treeconnect request tree.  (for SMB2), but will provide one again after the reboot.

I had the same problem with MyLiveDuo 4TB; after contact WD support, the only solution was to transfer all files to another drive, which I did on a new LiveDuo 8TB, and initialize it to factory reset.

Now the same problem I have with teh new 8TB, knowing that transfer was not so easy because I had to reset the drive 2-3 times a day in order to accress files.

Note that IP setting is on static and not DCHP, and when the drive is not recongnizable on the network, you can still access theough webserver.

Now the question is, when WD will offer a solution for this serious problem???

I face the same problem from the very first day i bought MyBookLive Duo. The disk was loosing internet connection randomly every few minutes. Following the instructions of technical support i had to go to factory defaults which did not solve the problem, resulting replacement of MyBookLive Duo. Of course you can understand how painful is to transfer your data from MyBookLive Duo having the mentioned problem; it took me three days of work.

Unfortunately the new unit behaves exactly the same. I’m lucky since my son investagated decided to investigate the problem and after a few simulations of the crashes he found out that the are (for the moment) two serious sotfware problems which were sent detailed report to WD two days ago; one is related with DLNA daemon which is responsible for media sharing crashing, and the second is SMB daemon responsible for windows-compatible file sharing crashing.

I hope that WD will resolve the isssue very fast…

Hi guys, this issue has been reported, I will reply back to this thread once I get some news. 

thanks; when can we expect a solution? it is becoming serious.

I have noticed that everytime you add files, the cut on the Network will occur more .

I guess I have to count myself lucky. I have seen no problems like this with a MBLD 4 TB (now 6 TB.) I would really like to know what the differences between setups are, though. It would be good to know if there is something to avoid.

I wonder till when we have to wait for the solution; it is becoming frustrating now. I have to reboot my drive 2-3 times daily to access my data.

It could be much better if WD says we have no solution and I will buy another NAS from another brand.

please advise,



Finally i found this threat

I have the same probleme. i receive a email all the time for notification. and since i did thes (5days now) i received 38 emails with info: reboot. all 3-4 hours i guess.

Problem is also, my itunes is linkes to it. an everytime i have to newly connect itunes to the nas.

i will try with the static IP adress…


I’m not in reach of my MBLD at the moment, but it occurs to me that I have most or all of the media functions turned off. On the other hand, I have really hammered the unit with file transfers and benchmarking from Windows 7. I have not had this disconnect issue while doing this.

I wonder if there is some kind of interaction or conflict between DLNA and SMB which causes the problem.

DLNA is trying to create thumbnails of the disk media content. During this process for unknown reason it crashes filling the temporary folder with trush.

The temporary folder is aslo used by Samba. As long as it is filled with trashes, consequently crashes Samba.

If the trashes sre delete while leaving DLNA crashed, there are no longer issues with Samba and file sharing is working properly without any restriction.


Check the following link (

It is dissapointing, my MBLD is not operational since last February…

If you want a DLNA server, install Twonky. I any case, you should disable the WD DLNA server. Lots of users report problems with the media server of the Live Duo.

Best, Till

Yes!  Am I glad that this has been called out!   This has also been happening to me since Day 1, causing me hundreds of hours of trying to figure this out and fixing it and repeatedly just shelving/moth-balling my MBLD and looking for other solutions.   It it disconnects so often it is useless. _ This would be like having a car that stops a few times a day and needs a jump each time to reboot it!!!  _ It is serious!

Please Western Digital or anyone in this community let us know an existing or new solution ASAP!!!

I have tried all solutions so far from fixed IP to disabling DLNA and nothing works. I hope these guys at WD have ears to hear how many times I sream daily.

Okay… just looked at the MBLD reviews on and many, many people spoke about the topic of this tread… constant disconnects from the MBLD from the local network.    This product simply is not working effectively.   PLEASE WESTERN DIGITAL BACK YOUR PRODUCT UP AND MAKE IT FUNCTIONAL OR DISCONTINUE IT.  BY CONTINUING TO SELL IT AS IS, YOU WILL DEGRADE YOUR COMPANY’S REPUTATION FURTHER.  If there is something that you truly think all of us are doing, please post a comprehensive list of fixes.  These are not isolated cases.

This forum has repair guides for fixing the MBL yourself;  try to use them instead of waiting helplessly for WD or someone else to fix your problem for you. 

1)Do factory restore with rear button

  1. Do factory restrore with Dashboard

3)Reinstall firmware manually from Dahsboard

  1. use SSH to trick MBL into thinking it has old firmware, then do firmware upgrade

  2. Do debrick proceedure

Thanks for taking the time for the feedback wdlive76.  That said, I read it first thing this morning and was extremely offended by your blatant and unfounded assumption that I was “waiting helplessly for WD of someone else to fix” my Problem.   Where the heck would you get that from and why lash out me like that – I am a human being, not a comment.   fyi: 1) I have spent absoltuely, literally 100s of hours trying to solve this problem, as have many others and while I might have missed this, I have not stood by helplessly; 2) I am not stupid, nor lazy (have many advanced degrees) and can typically work my way through these things; 3) I am somewhat tech savy, especially for a home/small biz user – for which this product is meant for.  That said, as this is called a COMMUNITY, I did expect support and respect from my “neighbors.”

This problem is not just my problem, as you can see from others on this webpage and many, many, many reviewers on Amazon ( ).  There is indeed something systemic that is happening with this product for which WD is responsible for and needs to be fixed as many, many, many of the reviewers on this site, Amazon and elsewhere have reported being extremely frustrated and junking that which they paid good money for.

Your fix associates this with “bricked” MBLDs.  During my research I have seen this fix associated with “bricking.”  I did not believe my problem was bricking (which I believe to be complete lock-up of a device).  As per the title of this thread and commments on Amazon and elsewhere – the problem is intermittent connections to the local network.   I do not believe my problem is bricking.  I have seen many referenes to factory restore as a fix – which is similar to when a technician tells customers to reformat their PC hard drive – the implication being that all work by users done to that point in time is thrown out the window – which I do not want to do, nor I believe would you.   That said, if I thought this was the answer, I would do it if I knew this was a definitive fix.  However, I am very skeptical as I have read other people’s reports that this does not fix the problem – so after a lot of work, I believe it is likely that this will be the case.

That said, as this is a systemic issue with something in the hardware or the software supplied by WD, as so many users have experienced it, I fully expect that WD would be transparent enough to state why this is happening and how it can be permanently remedied for me and the many, many, many users that experiences the same things.  This is not just about me – it is about the borader WD community and I am hopeful after this long message that you get that and treat others as respectfully as you would like to be treated.

That said, as I would like this to be more than an aswer to your rude response, I again appeal to WD or any other member of this community to explain why this happenting to me and so many other users and what can be done to DEFINITIVELY reconcile the problem.  Thank you community.


We can understand your frustration, so we escalated the issue you were having with the drive.  Please keep an eye on your private messages, someone from WD may contact you to get more information from you in order to replicate the issue.