MyBookLive Duo accessable from iPhone/iPad but not from Macbook Air

Dear Community,

I got today a 4 TB MyBook Live Duo based on reviews from alot of users and spent the last 5 hours setting it up to work with my wireless router and my MacBook Air and iPhone/iPad. I can’t believe that it is marketed as “Plug and Play” device. I am quite IT savvy and it took all this time and still did not achieve a full functioning network storage.

The current setup is as follows:

1- MyBookLive Duo connected directly to a wireless Router (Huawei Echolife HG521 Router).

2- MyBookLive has a reserved fixed IP address assigned to its MAC address

3- The Router is setup with DHCP enabled and UPnP enabled. The router does not have any multi-cast DHCP option.

4- MyBookLive is setup with DHCP enabled.

I was able to intermittently find MyBook Live Duo and MyBook Live Duo Backup on Finder on my MacBook Air but after few seconds it disappears.

MyBook Live Duo is accessable from my iPhone and iPad using WD 2Go application however all my data that I need to move to MyBook Live Duo is on my MacBook Air and I cannot seem to be able to make the MyBook Live Duo visible on the Mac.

I have already upgraded the firmware today.

Any quick help will be much appreciated.

Many thanks

Before you dismiss the MyBook Live Duo, and I write this from experience of assisting a few others on this forum, please check your router. I’ve encounteed a few instances where a router’s firmware was at the root of the problems and not the MyBook Live or MyBook Live Duo.

First thing to try is make sure your Routers firmware is up-to-date.  Maybe try another router if you can borrow one?

Hi Myron,

Many thanks for the feedback. I read several other posts relating to the router and I have done all the changes proposed and it did not work.

My confusion is that if it is a router issue, why do both my iPad and iPhone connect seamlessly to the MyBook Live Duo and I can even upload photos from those devices.

As mentioned before, from time to time, the MyBookLive Duo link is shown on Finder but as soon as I click on it it disappears.

Any additional suggestions would be much appreciated.

I would remove the fixed IP address that you setup in the router and create a fixed IP address directly on the Dashboard of the NAS itself. Try accessing it that way, should help.

My handicap with this is I don’t have anything Apple here. What I do know is that the MBLD I got really did Plug-and-Play.

How are you trying to authenticate and conect to the MyBook Live Duo?  Have you tried to authenticate and connect to the MBLD using the SMB protocol?  This is a trouble shooting step to try find out if the MBLD disappears from Finder using another protocol.

Something you could do is download the MBLD log files and examine those for anything that could apprear out of the ordinary?

Hi Both,

Many thanks again for the support. I think I finally made it work.

1- After removing the fixed IP address on the router, I set up the NAS and the router using DHCP.

2- I opened Finder -> Go-> Connect to Server and inserted the IP address of the NAS.

3- I connected each folder one at a time.

This seems to work for me for now without any interruptions.

Another reason for examining the log files on the MBLD is in case some process crashes and re-starts which would cause the MBLD to dissapear on the Mac’s finder and then reappear… Even though it now works, still grab a copy of the MBLD’s log files.

On the MyBook Live I had a similar problem when I tried to use Microsoft’s SyncToy application. A number of files would copy asnd then the MBLD would vanish for about a minute.  The log files revealed that the Samba daemon panicked and crashed. the MBL’s Linux kernel was configured to re-start Samba if is crashed.

So…  Have a look at the MBLD’s log to see if this may be happening. If it is then Western Digital product support needs to know about the problem.

xiownthisplacex wrote:

I would remove the fixed IP address that you setup in the router and create a fixed IP address directly on the Dashboard of the NAS itself. Try accessing it that way, should help.