MyBookLive Does Not appear on Windows 7 Computer Listing

I have a 1TB MyBookLive that was working fine on my network two weeks ago. A power outage in the middle of the night zapped my 2TB and after a week I figured out how to restore and things were good. Then a week later the 1TB drive disappeared from the network for no reason. The modem/gateway was replaced a few days ago due to technical issues and now the 1TB shows but only as a Twonky media server. WD Discovery also sees it as a media server but not as an NAS device.The 2TB shows up as both. The WD Dashboard only shows the 2TB drive. Is there some other setting in Windows 7 that needs to be changed to access this drive again or do I need to install another copy of WD Discovery to see this particular drive? I would think that the one copy of WD Discovery would see both drives since it does see them both as media servers. Open to suggestions.

Hello,

Try resetting the drive and doing a power cycle. Then try following the instructions found on the link below.

Device will still not show as a computer or storage device after reset
and power cycle so that mapping it can be done. Still only shows as a
media device. on the Windows Explorer map. I can not get into a WD
Dashboard for this drive to see if I can even change the name which
worked for a previous drive that was giving me issues.

:frowning:

Are the 2 NAS devices both MyBookLive? If so, this may be as simple as both devices now having the same name: MyBookLive. However, if everything was working for a week, that seems unlikely.

To be sure, you need to get to the devices Dashboard.

You should be able to get IP address of the uncooperative device from your router - i.e., your modem/gateway. You might also be able to get it from WD Discovery. (I’m now using WD QuickView. I don’t remember what Discovery shows.) You will be able to get to the MBL Dashboard from a browser using the device’s IP addr.

I recently had to fight a problem with similar symptoms, but it was following a reinstallation of Windows - Win10 - and the default setting prohibited a NAS connection. That is probably not your problem.

One was named MyBookLive and one was named MyBookLive2. Changed the
second to MyHomeDrive and it has been fine since then. WD Discovery
only shows MyHomeDrive as both media server and NAS. MyBookLive-Twonky
is media server only. Using IP address from both internet service
provider and WD Discovery does not bring up dashboard for drive. I can
get the Twonky Media Service part of it to come up using the IP
address. If I could get the dashboard up on the sick drive, I could
change it’s name to something else which might keep it from going down.

:frowning:

I suspect that getting to the media server but not the dashboard indicates that something is wrong in the device. Doing a reset to factory defaults is always an option, but not a very nice one. Hopefully someone more familiar with the device will chime in and offer better suggestions.

But in the mean time I’ll ask more questions.
You mentioned trying the IP address provided by your ISP. Do you have Remote Access enabled on your drive? (I’ve never enabled this. It always struck me as a huge security hole.) Does your computer use this address to access your MBL, or is the connection use local (private) IP addresses? What is oyur network configuration?

No remote access enabled. All devices IP addresses are handled by
gateway/modem and are dynamic. Reset to factory default has been done
to no avail. The entire network is set up through the modem/gateway.
When the drive went down the first time last week, it came back up after
the computer was accidentally shut down by a power surge. That lasted
about a week. MyHomeDrive crashed after the power outage and took four
days for me to get it back up. Everything runs on a Home Network via
Homegroup. It is possible there is something amiss in Windows 7 since
these were all working fine until two weeks ago when the power went out
and killed the mapped drives.

:frowning:

I would suspect Windows, too, except I thought it is getting at the other NAS with no trouble. That means the general settings must be ok.

Are the shares set up as public or private? If private, Windows might have a saved set of network credentials that are no longer correct. There are several web pages describing how to display and clear saved network credentials.

I’ve never been successful in getting Homegroups to work consistently so my knowledge of them is pretty feeble. I do know the MBL has a Homegroup name in its network configuration. It’s default name seems to be “Homegroup”. Having a name mismatch might prevent Windows from discovering the NAS, but it wouldn’t prevent you from getting to the MBL Dashboard by IP addr from a browser.

Something to try: bring up a command prompt window on Windows and do an NSLOOKUP for your 2 NASs (MyBookLive and MyHomeDrive). If Windows’ network discovery is working correctly NSLOOKUP should display the IP addr of the devices. If neither address can be resolved then something is wrong with parms controlling network discovery - the advance network sharing options. If only one address is resolved then either the device can’t be reached (in which case, you shouldn’t be able to get at the media server) or something is hosed over in Windows’ network discovery other than the parms. Rebooting might fix it. (I had just that problem a few weeks ago - I could reach a NAS by address but not by name. A reboot fixed it.)

While you’ve got the command prompt window up, try PING by IP address. Unless you’ve got a firewall blocking PINGs, you should be able to reach the device unless it (or Windows) is totally brain-dead.

I am guessing that the shares are set up as public since no password was
needed to access them. Both drives gave back an IP address so they are
accessible and the drive that is not showing on the network does give a
response when it is Pinged (That is one of the first things I checked).
A reboot might end up being the key since it was an unplanned power
outage that made it come up last time but I would prefer that that be a
last resort because I would hate to lose the one drive that is working.
Rebooting the gateway/modem may also be an option. There was one other
message that came up while I was doing testing on the network that I
have seen before but I was able to fix that by renaming NAS drive on
dashboard which I can not do now since I can’t get into that drive’s
dashboard. :frowning:

Hi Richard, I know your post is from number of years ago however I’ve just encountered exactly the same issue after I moved the network drive to another location in my house (it was turned on and off a number of times in the process). Now I can’t see it as a network file storage device with either of my two windows machines (win 7 and win 10) but can stream the movies and other media files from it to multiple apple devices and to the media player on the windows machine. So the drive is still on the network with the correctly assigned IP address but unless its a media file is inaccessible. I can also see it as a media server in windows explorer / my computer but not the windows file structure as a set of folders. If I double click on the media drive icon I can get the config page and go to sharing, all the files are still there (including non-media files) but they are unable to be launched. The issue is that it has a lot more than just media files on it as it was also being used as an external hard drive for general file storage. None of that is accessible now if I can’t map to it in explorer.

My next move will be to pull it apart and attempt to install the drive directly in my windows 10 device a as a third HDD to see if I can do a DOS based copy of all files to another location but I’ll probably break the device in the process.

Were you able to fix your issue and do you remember what you did?

Mybook Live HD is formatted with XFS filesystem so a Windows machine can’t directly access to the files.
Windows probably will ask you to format the disk if directly connected to a SATA interface of you Windows PC.