MyBookLive Directories go offline but administration webpages still accessible

I thought I finally had my MyBookLive Duo up and running the way I desired but it will operate fine for a little while and then the directories just go offline and become inaccessible.  I can get still get to the administration pages and everything appears okay but the only way I can gain access to the directories again is to unplug the device and plug it back in again.  The directories remain available for a couple hours at best.  

I have numerous devices that access these directories.  Win 7, Win 8, and a picture frame that mounts the directory.  All of these devices lose acdess concurrently when the directories encounter a problem. 

Any ideas on how to solve this problem?  Is it solvable or am I possibly looking at a faulty machine?

Thanks in advance.

Update: Today I was unable to access the webservice of the NAS too.  The green light is on. 

Try mapping the drive and see if problem persists.

Mapping a My Book Live, My Book Live Duo, WD TV Live Hub, WD ShareSpace or My Book World on a Windows PC

I have been mapping the drives.  It doesn’t make any difference.  It just makes for a bigger headache when it loses its connection.  

Any other ideas? 

Experience exacly the same issue too. i  fixed it by turning off the sleep mode

Even after turning off sleep mode, the device still randomly loses its mind. It happens every few weeks for me.  Really frustrating.  I lose access to the shared directories, but can still access the admin panel via IP address.  If you reboot from there, it seems to solve the problem.  

There is definitely something flaky with the control software. 

My guess is that the Samba process is dying. You might check the system logs via SSH for clues. They’re located in


Tony, thanks for the advice.  Not to be too snarky, but what good would it be for me to know this answer?  This is supposed to be a consumer device that should just work.  I’m reasonably competent technically, but this is one of those devices that I don’t want to think about.   

Well, it’d be good to know if it’s the server’s fault (and pin it down to exactly what) or if there’s something else going on.