MyBookLive Dashboard Blank screen

When I try to access my MyBookLive Dashboard using http://mybooklive/UI/ , I can get in past the password screen, but the display is always BLANK. I can’t access (view or amend) any of my settings.
Any ideas on what has gone wrong, or what I can do to repair this please?

I have read and tried this option:
…but with no success. I’d seen that before and I was hopeful that it would work. It gave no error message, appeared to login with the correct URL but I get a completely blank screen.

I was wondering if I did a factory reset, if that would restore my access. I read some posts that other users found this useful. However, having downloaded Putty.exe, I tried to access the SSH to allow access but that also gave me a blank screen too. I’m a little stuck now. Is there a reset button option on the hardware that I can use?

Or any other option.

There is a reset button on the back. Press and hold it for 4 seconds while it is powered ON.

The MANUAL Page 125 for rest instructions.

Are you able to access the drive as a device on your network?

Yes, I’m able to access the device. Will it clear / format the drive, and therefore I need to ensure it’s 100% backed up? I believe it is already, but just double checking.
Thanks for your reply.

Not sure about a FULL reset or if it’s a partial reset. So…backup before you do it.

Thanks for your help. I’ll do that, and post back if this is a solution or not.

The reset button at the back had no impact. The data wasn’t lost, but I had it backed up anyway. The drive came back down, and when I went into http://mybooklive/UI/ again, the screen was still blank. It means I can’t get to any of the administration settings etc. All the users, and data partitions are still in place, as I can access those areas from setting the areas via ‘Map network drive’ within File Explorer.
Just frustrating not to get to any of the admin settings.
Any further thoughts?

Man…that’s a tuff one… I wonder if using the IP of the MBL instead of the mybooklive would make a difference…like is how I access mine.

Also there is a thread here about debricking one of these things. The guy that started that thread is very knowledgeable. Perhaps following the debricking instructions mght bring back the settings page. Or he might know of something to try @nfodiz. He was a big help to me when I replaced the drive in mine. Hopefully he’ll read this now that I’ve mentioned his name. :slight_smile:

Here’s the LINK to that thread.

A quote from the beginning of that thread reads “DISCLAIMER
Be aware that this will void your warranty and is only to be used as a last resort when you have no dashboard or SSH”

One other thought - You are at a point where you have nothing to lose and everything to gain. If you can’t get the dashboard back you can always pull the drive out, buy a new diskless NAS device and use that drive in it. You will lose all the data as the drive will have to be formatted for the new NAS to use it. A single bay NAS can be had for 99.00. Just a thought…

Yes, that’s an odd one. The device is obviously working or you wouldn’t be able to access the data. What happens in your browser when you try to access the dashboard? Does it finish displaying but displays nothing, or is it hanging waiting to receive something? Any chance you have some security software - either a firewall or something in the browser itself - that may be blocking access?

Agreed. It’s worked perfectly okay for years, but the last 2+ years it just gives a blank screen, no error message. Initially I had teh normal ‘logon’ screen, entered my admin password, and got the blank screen. So I removed the Admin password and nothing changed other than it ‘logs in’ direct.
I have no error messages, and the swirling on the tab completes within a few seconds.
I had the same view when I tried to access the SSH. So I’m stumped. I’m wondering whether any hardware update to the MyBookLove caused this change. I’ve tried logging in via other computers, and get exactly the same issue. My virus security software (McAfee) hasn’t changed in years either.

Thanks @flhthemi for your post and I read the thread by @nfodiz, for the 3TB MBL. I understand the process, and at this point as I have a fully functional (and accessible) Network drive (other than the Dashboard access), I’ve decided to let it be.
I do have the data backed up, so until/unless the lack of dashboard creates me a problem in the future, it’s perhaps best left alone.
I do appreciate everyone chipping in.
Thanks to all.

Chicken :slight_smile:

See, I just could not stand it and would have to do it because I just can’t stand having something that isn’t fully functioning.(But that’s just my OCD kicking in) Which I did when my drive in mine took a dump and I won! It became a challenge and now I want to do it again this time with a 4TB drive just to see if I can do it :slight_smile:

Ha, you are absolutely correct.
I work to the phrase “If it’s not f**ked, don’t fix it!”.
That way, I will still have a network drive that I can still use.
However, if/when the situation changes, I know what to do.

There is a reset button on the back. Press and hold it for 4 seconds while it is powered ON.

This may seem bizarre, but I encountered the same issue trying to get my MyBookLive usefully functional. You likely have a browser issue, and clearing your cache may fix it. Trying to force reloading the page the page stayed blank, but using a different computer or browser also worked.