Mybooklive, can someone please help?

I have tried to get answers but gets responses that make it seem as if I already know what I am doing, which aren’t helpful. I have a 3tb mybooklive NAS. It is attached to my Netgear nighthawk R700 router. My PC is wireless. My PC is a dell XPS i7 with 32 GB ram. I cannot copy or move a file from mybook to my pc wirelessly without getting more than 300kb per second. Plus every time I right click a file, it hangs forever. It sometimes takes 6 hours to copy a 2gb file from NAS to pc. I have no idea what to do.

The only thing new is my router, and that my pc in not hard wired to my router. Which it was before and speeds were great. Now, it is a mess. I shoudl be able to transfer files at a faster rate than 300kb, and not have to wait 30 seconds for “copy” to appear after right clicking. It takes forever to load a folder, the NAS is always spinning up when it isn’t being accessed. All tests say the nas is fine.e What can I look at to fix this?! Hard wiring my pc to the router isn’t an option at this point.


Have you check the firewall setting on the new router?

Transfer speed will depend on the environment and how far is the computer from the devices.

My firewakk is on my modem, but I not use my modem for wireless. And I have full connectivity. When you say check your firewall, check what?


Unfortunately there are many things that can cause wireless speeds to be low. Since this is a WD forum, and your Mybooklive is fine, I am afraid you won’t find many answers here.
A few things to check:

  1. speed beween router and NAS. Is it 1Gb? If 100Mb, then around 8MB/s will be your max if configured as duplex
  2. In Windows, open “wireless network connection status” and look at your speed while transfering a large file (take a large file to transfer, so you can observe the wifi speed changing). In my case it can drop to 12Mbs, in which case I will not see transfer rates better than 400 to 500 KB/s due to retries, packet forwarding in your router.
  3. Check if your router has a firewall enabled. That reduces speed even more.
    If your router is on your intranet (and not DMZ), no need for double firewall.
  4. Run “netstat -es” on your PC before and after running a transfer test.
    Look at errors. segments retransmitted etc. There is no easy way to reset netstat counters except reboot or disable/enable your wifi (at least that I know of). Look at ratio of segments sent/received and retransmitted.

Good luck troubleshooting.